Skip to Content
0

Issue with getting field populated in the Webclient UI

Mar 13 at 02:20 PM

17

avatar image
Former Member

Hello,

I am facing a very wierd issue with the Webclient UI.

I added a field ABC to the AIC_CMCD_H component through the AET workbench.

I created a search help DEF using SE11 (the search help doesn't have search help exit)

In the AET i set the search help for field ABC to be the DEF search help and generated the field.

I went to the AIC_CMCD_H component and redefined the GET,SET,GET_M,GET_I for the field and kept the code as it is without changing it.

I went to the screen and the field is there with the correct list of values when you press F4, then i picked a value and the value is shown in the field.

The problem is when i press the F4 and press the "Search" button. when i do that and pick a value the value is not shown in the field and it is not returned to the screen.

I can't seem to figure out the problem as it is working when the initial F4 list is shown. what so special about the "Search" button? and how can i fix the issue?

Regards,

Roi Grosfeld

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Varun Agarwal
Mar 15 at 07:34 AM
0

Hello Roi,

Could you please confirm if following SAP Notes are implemented in your system

2389724 Selection from F4 value help does not work
2397663 Selection from F4 value help does not work - Part 2
2436159 Selection from F4 value help does not work - Part 3
2441891 Dropdown list box is not filled from Value Help popup
2446409 Search does not work in F4 Value help popup
2453742 Various problems with F4 Value Help

Best Regards,

Varun Agarwal

Share
10 |10000 characters needed characters left characters exceeded