Skip to Content
author's profile photo Former Member
Former Member

Search Help

Hi all,

am facing a typical problem, can anybody suggest solution to it......

I have a filed like FKART i my Z-table, having data element and domain and search help as it is in the standard table VBRK.

problem is if i refere my z-table filed FKART from my z-program, then am not getting the F4 help in integration sysyem, but F4 help is comming in the development as well as in pre-production sysyem.

please suggest any solution....

thx in advance.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Aug 07, 2008 at 05:26 AM

    Use the match code object for the parameter in your program.

    or

    At the data element level their is a tab with further charecteristics specify the search help name in the further charecteristics of that table .

    Thanks

    Krishna Bommisetty.

    Edited by: Krishna Bommisetty on Aug 7, 2008 7:27 AM

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 06, 2008 at 05:10 PM

    Hi,

    Try this

    Attach the search help to the field in the Z - program using matchcode statement in the selection screen even though the field has the search help in the Ztable

    Also check whether the search help attached to field exists in the integration system.

    Thanks,

    Muthu

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 11, 2008 at 10:18 AM

    Hi,

    The problem is due to the previously attached Standard Search help with the Domain of your Table -Field.

    This can be solved by creating a search help of your own and then attaching it to the Field present in your table.

    1. Go to SE11 and create a the Search Help for the field.

    2. Attach it to the field inside your table.

    Regards.

    Amit Bisht.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 12, 2008 at 05:01 AM

    Hi,

    Goto SE11 and create match code for the FIeld. And the explicitily mention that in that select option.

    e.g:

    SELECT-OPTIONS : s_coprc FOR g_coprc MATCHCODE OBJECT zfi_tfk070b_copr

    Regards,

    Prashant.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.