Skip to Content
-2

Getting Invalid Parameter @EnterpriseSearchHana.identifier

CALL ESH_CONFIG('[{ "uri": "~/$metadata/EntitySets", "method": "PUT", "content":{ "Fullname": "ANA_FAQ/V_ISSUES", "EntityType": { "@Search.searchable": true, "@EnterpriseSearch.enabled": true, "@EnterpriseSearchHana.identifier": "DETECTEDISSUES", "@EnterpriseSearch.fieldGroupForSearchQuery": [ { "Name": "ISSUE_FIELD_GROUP", "Elements": [ "QUESTION_ID","QUESTION" ] } ], "Properties": [ {"Name": "QUESTION", "@Search.defaultSearchElement": true, "@Search.fuzzinessThreshold": 0.9, "@EnterpriseSearch.presentationMode": [ "TITLE" ], "@EnterpriseSearch.highlighted.enabled": true}, {"Name": "QUESTION_ID", "@Search.defaultSearchElement": true, "@EnterpriseSearch.presentationMode": [ "HIDDEN" ], "@EnterpriseSearch.key": true} ] } } }]',?);

RESPONSE :

{"error":{"code":"8103113","message":"Configuration failed","details": [{"code":"8103102","message":"Invalid parameter: '@EnterpriseSearchHana.identifier'"}]}}

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Mar 13 at 07:07 AM

    I would be great if you would share some more information instead of just posting an error message. E.g. it would be of interest which HANA version you are using. I assume that you are using a HANA version older than HANA 2.0 SPS01, because the annotation for which the error occurs was introduced with that version. If you are using an older version, than you get that error message, cause the annotation simply does not exist.

    Regards,
    Florian

    Add comment
    10|10000 characters needed characters exceeded