Skip to Content
0

Account Modifier is not working in EBS - Electronic Bank statement MT940

Mar 10 at 10:02 PM

66

avatar image
Former Member

Hello experts,

Could you plesae help on this issue? I am trying to post EBS (MT940) for multiple company codes with single statement file. Few of the accounts use Account Modifier. Among st these, for one bank account, the account modifier is not at all considered. system takes the GL account from the general Account symbol (from "Assign Accounts to Acc. Symbol) where the Account symbol and Currency are "+" and GL is ++++20. This is bank master GL acc. The ex.trans type is NCMS with "DP" (ZERO Balance) and business wants to post the Dr and Cr to non bank GL. I tried changing the Account Number (:25:) in the EBS with other Bank Accounts. for all other accounts system picks the GL from line where Acc Modifier is given. Contry -UK.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

MaDhU ReDdY Mar 11 at 10:55 PM
1

I think you didn't mention about how Account Modifier is derived eg Search string, Enhancement etc. You should check on what condition Account modifier is determined and trouble shoot further.

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 12 at 09:06 AM
0

Hello Madhu,

Thanks for the inputs.
There is no search strings added. In the OT83 (Assging ext Trans type to Posting Rule) there is no interpretation activated. The assigned one is "0" 00 - No Interpretation.
Back to your question ->How Account Modifier is derived:
In the Defile Posting Rule - the Account symbol for Posting Key 40 and 50 is mentioned. In the tab "Assign accounts to Acc Symbol" is specified how Account Modifier is treated. If there is no Acc Mod. is configured, system should use the general masking ->
Account Symbol "XYZ" | Acc Mod "+" | Currency "+" | GL ++++30

If another line with unique Acc mod. is configured with a particular GL, system should use that GL account. This is what I know, please correct me if I am wrong.

In my case, only for one bank account the rule is not working (GL in the general masking is triggered). For all other bank accounts Acc Mod ->GL is posted.

Please help

Thanks,
Linus

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Mar 14 at 05:11 PM
0

Hello,

The issue has been resolved
The error was in the standard exit. T.code SMOD->Enhancement - FEB00001 "execute"
EXIT _RFEBBU10_001
In this they used a custom table to validate the company codes to enable account modifier. I added the company code, it worked fine.

<Closing the thread>

Share
10 |10000 characters needed characters left characters exceeded