Skip to Content

MRP Lot-size type "MB" with maximum stock level, How to set?

Hi, experts.

I got a requirement from my client that

- Execute MRP with

1. MRP type : PD

2. Lot size type : MB

3. It has to be considered "Maximum stock level" and don`t get exceed by its level.

As my understanding, "Lot size type : HB" is considered "maximum stock level" only. MB doesn`t take account with that "maximum stock level".

Is there any way to do that with type "MB"?

Now I`m considering the BADI "MD_CHANGE_MRP_DATA" to do this.

If you have any solution please inform me.

Thanks.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Best Answer
    Oct 31, 2016 at 05:07 PM

    Hello

    There is no way to achieve what you want on the standard system. In addition, BAdI MD_CHANGE_MRP_DATA will only affect the display of the purchase requisition on MD04 and other MRP transactions and it won't save the results into the database.

    In addition, even if you save the results into the database, if the purchase requisition quantity does not cover all the requirements, a new purchase requisition will be created by MRP on the next MRP run.

    Regards,

    Caetano

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you for the comment.

      It seems like you are correct. There is no solution for my issue by standard system.

      So I developed the program to correct PR after MRP.

  • Oct 28, 2016 at 06:35 AM

    Hi,

    As Lot size MB will be for monthly planning it will not consider maximum stock level as for maximum stock level consideration HB is there .

    Both the lot size have different functionality .

    If client is not convincing than better go for devlopment MD_CHANGE_MRP_DATA

    Thanks & Regards

    Sandeep Kumar Praharaj

    Add comment
    10|10000 characters needed characters exceeded

    • Thank you, sir.

      I`m developing the BADI "MD_CHANGE_MRP_DATA~CHANGE_MDPSX_EBAN".

      And I got another issue with it.

      To excluding PR generation in MRP, I put the value "0" parameter "CH_MDPS-MNG01".

      It seems like work in MD04 but PR is generated.

      Do you know how to excluding PR in "MD_CHANGE_MRP_DATA~CHANGE_MDPSX_EBAN"?