Skip to Content
0

SAP GRC Links not showing up

Mar 09 at 08:29 PM

76

avatar image

Hi,

I am looking on how to "unhide" a link under Access Management tab in Access Control.

Already tried the following:

TCode: LPD_CUST->Change Launchpad->Access corresponding folder and then the app-> Right-click: App Invisible-No; App Disabled-No. Every option have SAP default values but two out of three links are not showing up.

We can add the link by opening the Service Map in Config-Mode but this is not the solutions since the links were visible before with SAP Standard.

This is for SAP GRC AC 10.1

SP Level 0015

Please advice.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

5 Answers

Best Answer
Lynette Nieves Mar 14 at 12:17 PM
0

I am able now to see the links by:

Role: GRACACCMGMT

Instance: GRC_SUITE_ACCESS_MANAGEMENT

Advanced Parameters->leave blank "Add Information" field. I tried in this folder your suggestion of copying the link that worked, and it worked until I put this parameter so I just left it blank and it worked. Do you have any information on this field? It also says that the launchpad does not use that data.

Not sure what is the difference between roles GRACMGMT and GRACACCMGMT, but in the first case I was not able to make any change in the LaunchPad.

Share
10 |10000 characters needed characters left characters exceeded
Yashasvi Sanvaliya Mar 12 at 05:52 AM
0

Hello Lynette,

You can open the page (app) in config mode and make links visible again. Which are these links? As per SAP standards, the links were visible, so somebody might have changed the config (probably by opening page in config mode). Could you please share few screen shots that will help us understand the issue better?

Kind regards,

Yashasvi

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Yashasvi,

Links are for "Manage Coordinators" and "Manage Rejections" under Access Management->Compliance Certification Reviews.

I already opened the page in Config-Mode, and the links are not available for me to change them:

Note that "Request Review" link is ok for any change. The "[Decoration] Manage Coordinators" was added manually in config mode (since none of the other options work) and seems like this:

Obviously we don't want this since it is a totally different configuration.

Please advice.

Thank you, Lynette

0
Ramesh Vithanala Mar 12 at 12:53 PM
0

Hello Lynette,

Please refer to the following SAP Note : 2615709 - Missing tab or link in NWBC(KBA)

Thanks

Ramesh

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Ramesh,

Note 2615709 was already verified since it was open when reported this incident with SAP.

It does not work because of the following reasons:

All the links are enabled and "set as visible" in "Configure LaunchPad for Menus" (or LPD_CUST). They are in standard SAP configuration.

Point No.7 (second option) on this note is for "unhide" the links by right-clicking. Opened the page in config-mode to check if links were "hide" and none of them are available for configuration (see screenshots for previous comment). When right-cliking on the links there is no option for me as and admin or end user to hide or unhide links.

Not sure if I am missing something on this.

Thank you. Please advice,

Lynette

0

Update on this answer:

I was able to open the settings by enabling user personalization. Right-clicked but the links, as said before were not available for hide/unhide. Only for "Request review" which is working fine. There are no other "Hide" Links to "Unhide".

Regards,

Lynette

0
Ramesh Vithanala Mar 13 at 03:23 PM
0

Lynette,

Its weird,Did you try creating a custom link by copying the request review and change the application to

GRAC_OIF_MANAGE_REJECTIONS and Add Information to MENUITEMID=0GRACCUPREJECTIONS?

Just want to see how its behaving and also did you run the report APB_LPD_CORRECT_TEXTTABLES in the system that you are having issue.

Thanks

Ramesh

Show 3 Share
10 |10000 characters needed characters left characters exceeded

Hi Ramesh,

See my answers in bold

Did you try creating a custom link by copying the request review and change the application to

GRAC_OIF_MANAGE_REJECTIONS and Add Information to MENUITEMID=0GRACCUPREJECTIONS?

Yes. Tried first to create a new one with corresponding values for Manage Coordinators, then by copying Request Review with the Manage Coordinators values for Application and Add information. I also tried to change "text" for the links that are working and the changes are not reflected on the Frond End.

Just want to see how its behaving and also did you run the report APB_LPD_CORRECT_TEXTTABLES in the system that you are having issue.

I did run the report for GRACMGMT role with GRAC_ACCESS_MANAGEMENT instance. Result: Texttable is correct, no correction needed.

Regards,

Lynette

0

Lynette,

Can you share the screenshot of the LPD_CUST(Overview of Launchpad) and also change Launchpad - Role :

GRACMGMT role with GRAC_ACCESS_MANAGEMENT with advanced parameters

Thanks

Ramesh

1

Hi Ramesh,

I am able now to see the links by:

Role: GRACACCMGMT

Instance: GRC_SUITE_ACCESS_MANAGEMENT

Advanced Parameters->leave blank "Add Information" field. I tried in this folder your suggestion of copying the link that worked, and it worked until I put this parameter so I just left it blank and it worked. Do you have any information on this field? It also says that the launchpad does not use that data.

Not sure what is the difference between roles GRACMGMT and GRACACCMGMT, but in the first case I was not able to make any change in the LaunchPad.

Best regards,

Lynette

0
Lynette Nieves Mar 12 at 08:55 PM
0

Hi Yashasvi,

Links are for "Manage Coordinators" and "Manage Rejections" under Access Management->Compliance Certification Reviews.

I already opened the page in Config-Mode, and the links are not available for me to change them:

Note that "Request Review" link is ok for any change. The "[Decoration] Manage Coordinators" was added manually in config mode (since none of the other options work) and seems like this:

Obviously we don't want this since it is a totally different configuration.

Please advice.

Thank you, Lynette

Share
10 |10000 characters needed characters left characters exceeded