Skip to Content
0
Former Member
Aug 04, 2008 at 06:33 PM

Cannot refresh a stored procedure within a Crystal Report from Xcelsius

17 Views

Please help...Xcelsius 2008 & Live Office problem...

What I am trying to do is to refresh a stored procedure that is within a Crystal report from within my Xcelsius dashboard in Preview mode. The data returned appears on the Xcelsius dashboard. It works fine in Design mode, just not in Preview or when published as a swf.

1. I set up a Crystal Report using a Stored Procedure as the data provider.

2. The Stored Procedure has a parameter built into it.

3. When the report is refreshed within Crystal, the prompt dialog box is displayed; I fill in the desired value, and run. Everything comes back fine.

4. Crystal Report is exported to the repository.

5. In Excel, I inserted the Crystal Report using Live Office. It shows up as a Live Office object just fine.

6. I bound an Excel cell to the prompt; when you change the value in the bound cell, the Live Office object refreshes and displays the correct results.

7. In Xcelsius, I imported the Excel spreadsheet.

8. I set up a Text component that is bound to the cell containing the parameter value. Also set up a Grid to display the results, and a Connection Refresh button to call the refresh. Added a Live Office Data Connection pointing to the Web Service URL for the report.

Note: When in Designer mode, if the value of the bound cell is changed, the results in the grid change accordingly.

9. When in Preview mode (or generated swf), if the Refresh button is pressed, a "User Identification" dialog box appears asking me to log on. The values it asks for are: System, User Name, Password, and Authentication. I enter the same credentials as are within the Live Office settings in Excel, (which are working correctly), but receive an error "soapenv:Server.generalException: Database logon failed.".

Note - all the id's are synced up - Business Objects, Database, etc.

I've tried all kinds of combinations, but nothing gets me past this error. If I use any other server than the one listed under System in Live Office, the error message is "soapenv:Server.generalException: Server XXXXX not found or server may be down".

I've noticed that in Excel directly, when I open the spreadsheet and refresh the Live Office object, I am prompted to log on to the database where the stored procedure is being executed. This dialog box does not appear once the Excel sheet has been imported into Xcelsius. One of the combinations I tried in the "User Identification" dialog box was the name of the database server, that didn't work either.

I also tried creating the Live Office object directly within the Excel spreadsheet in Xcelsius, but then I was unable to bind the prompt value. Could never get the Live Office/Properties menu to appear.

Ideas? Thoughts?

Thanks in advance!

Stephanie