Skip to Content
avatar image
Former Member

Workflow multiple decision items execution restriction

Hi All,

I have created a workflow which requires that user is not allowed to process the multiple decision items at once. Currently user is able to select multiple items in his inbox and execute it. Only a pop-up appears to confirm if same action is to be copied for all other selected items. I want to restrict the same to execution of single item and not all at once.

It is a Bank Analyser sytem with SAP NETWEAVER 7.5 release.

Custom workflow with a Decision activity of Accept/Reject. Using SBWP for workitem approvals.

Add comment
10|10000 characters needed characters exceeded

  • Hi Aditya, Ok so that can people can help you, you need to give a bit more detail. For starters WHICH workflow inbox are you using? There are several. What type of system & what release? e.g. is it ECC 6.0 EHP6 or S/4HANA 1511 or what? Are your work items coming from Business Workflow or BPM or something else? Please edit your question so that there is sufficient detail for publication.

    Thanks

    Jocelyn, Moderator

  • HI Aditya, Yes that's getting better but you still haven't told us the most crucial detail - which workflow inbox you are using? Multiple approval works very differently under the covers in different inboxes. On SAP Netweaver 7.5 there are several available. It could be Fiori My Inbox, or the Enterprise Portal Universal WorkList, or the Business Client POWL list for workflow, or transaction SBWP. If you are really aren't sure which you are using, try and include a screenshot (blur any sensitive details) - we should be able to work out which it is from that.

    Thanks

    Jocelyn

  • Thanks ok that's clear! Transaction SBWP.

    Folks - anyone played around with restricting multiple selection in SBWP?

  • Get RSS Feed

2 Answers

  • Nov 02, 2016 at 07:11 PM

    The feature is 'Transfer of execution' and is enabled in a user's personal workflow settings. I've only ever had the requirement to enable it.

    As SAP provide it as part of a user's setting, there's no simple way to disable it on a per-task basis. My approaches would be:

    - Create a custom decision task that doesn't allow transfer of execution, or

    - Look for an enhancement point where a filter could be safely implemented.

    The first option seems the easiest.

    See http://help.sap.com/saphelp_nw74/helpdata/en/4f/2bba98ba2018c6e10000000a421937/frameset.htm for details

    Regards,

    Mike

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 03, 2016 at 07:25 AM

    Hi,

    I thinks popup is coming because you it in following menu Settings -> Workflow Settings -> Personal Settings -> Transfer of Execution . If you unchecked it then pop up will not come. Though you can select multiple line.

    Add comment
    10|10000 characters needed characters exceeded