Skip to Content

Data Manager Package Error - "Environment ID does not exist"

Hello experts,

I am getting an error while running a customized DM that has been recently transported from a different Enviroment.

1. Package Log:

/CPMB/MODIFY completed in 0 seconds

/CPMB/MASTER_CONVERT completed in 0 seconds

/CPMB/CLEAR completed in 0 seconds

[Selection]

--------------------------------------------------------------

FILE=\ROOT\WEBFOLDERS\UNPLAN\SUMMARY\DATAMANAGER\DATAFILES\MasterDataNew_By_Maleo.csv

TRANSFORMATION =\ROOT\WEBFOLDERS\UNPLAN\SUMMARY\DATAMANAGER\TRANSFORMATIONFILES\CONTENT_TRANSFORMATION_MD FROM FILE.xls

DIMNAME = CONTENT

DIMNAME_KEYDATE =

DIMNAME_DATEFROM =

WRITEMODE = 2

[Message]

--------------------------------------------------------------

No 1 Round:

Failed

Environment ID does not exist

model: SUMMARY. Package status: ERROR

2. Package Script:

PROMPT(INFILES,,"Import file:",) PROMPT(TRANSFORMATION,%TRANSFORMATION%,"Transformation file:",,,CONTENT_TRANSFORMATION_MD FROM FILE.xls) PROMPT(DIMENSIONNAME,%DIMNAME%,"Dimension name:",,,CONTENT,0) PROMPT(RADIOBUTTON,%WRITEMODE%,"Write Mode",2,{"Update Hierarchy"},{"2"}) INFO(%TEMPNO1%,%INCREASENO%) INFO(%TEMPNO2%,%INCREASENO%) INFO(%DIMNAME_DATEFROM%,) INFO(%DIMNAME_KEYDATE%,) TASK(/CPMB/MASTER_CONVERT,OUTPUTNO,%TEMPNO1%) TASK(/CPMB/MASTER_CONVERT,FORMULA_FILE_NO,%TEMPNO2%) TASK(/CPMB/MASTER_CONVERT,TRANSFORMATIONFILEPATH,%TRANSFORMATION%) TASK(/CPMB/MASTER_CONVERT,SUSER,%USER%)TASK(/CPMB/MASTER_CONVERT,SAPPSET,%APPSET%) TASK(/CPMB/MASTER_CONVERT,SAPP,%APP%) TASK(/CPMB/MASTER_CONVERT,FILE,%FILE%) TASK(/CPMB/MASTER_CONVERT,DIMNAME,%DIMNAME%) TASK(/CPMB/MASTER_CONVERT,KEYDATE,%DIMNAME_KEYDATE%) TASK(/CPMB/MASTER_LOAD,INPUTNO,%TEMPNO1%) TASK(/CPMB/MASTER_LOAD,FORMULA_FILE_NO,%TEMPNO2%) TASK(/CPMB/MASTER_LOAD,DIMNAME,%DIMNAME%) TASK(/CPMB/MASTER_LOAD,WRITEMODE,%WRITEMODE%) TASK(/CPMB/MASTER_LOAD,DATEFROM,%DIMNAME_DATEFROM%) TASK(/CPMB/MASTER_LOAD,KEYDATE,%DIMNAME_KEYDATE%)

any guidance will be appreciated.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

2 Answers

  • Mar 10 at 07:52 AM

    First - look on your post results: in the desktop browser there are no line breaks in the script code - impossible to read!

    Second: what do you want to customize??? Please explain what do you want to achieve!

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 12 at 06:58 PM

    Thanks for the response Vadim,

    I actually found the error on the customized Package Script which I fixed and got it running back again.

    Add comment
    10|10000 characters needed characters exceeded