Skip to Content

Netweaver PI 7.1 Java Version on Client Machine

Hi

I am being asked what is the maximum version of java I can have installed on my desktop machine, to enable me to do my work on SAP PI netweaver 7.1. dual stack. I currently have version 8 update 66

Is there information somewhere that can tell me versions required please? I've tried looking in PAM but not got very far.

I would need to know Netweaver PI 7.5 too, as we will be moving to that in the mid-future.

Many thanks

Elizabeth

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Best Answer
    Mar 09 at 02:56 PM

    Hi Elizabeth,

    SAP Notes 2073368 (Compatibility matrix: recommended Java version for Integration Builder tools of SAP Process Integration) and 1614742 (Using Java Web Start with different PI releases), as well as Wiki page on ESR/ID troubleshooting at https://wiki.scn.sap.com/wiki/display/XI/Troubleshooting+PI+ESR+and+Integration+Builder+Logon+Issues, are helpful when identifying which JRE is compatible with the respective PI release (as well as support of which more recent JRE releases has been introduced in corresponding Support Packages for older PI releases).

    For PI 7.5, you shall not experience issues using JRE 1.8 when running ESR / Integration Directory, while for PI 7.1, it will depend on Support Package level of your PI system (as mentioned Note suggests, JRE 1.8 it is supported in PI 7.1 SP19 and higher).

    Regards,

    Vadim

    Add comment
    10|10000 characters needed characters exceeded