Skip to Content
avatar image
Former Member

Resource adapter not present error on idoc sender channel

Hi,

We have Single stack PI 7.4 idoc sender channel is working and messages got exchanged successfully, but still the channel status show as error with Resource adapter <RFC Name> not present. This is the RFC we have sued in sender channel and created in ECC with type T.

Not sure why channel status shows as error still.. there isn't any messages got stop.

I have checked the inboundRA and restarted still looks good. and property local is true.

Please help by when it get turn to green ?

Thanks,

mahesh

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Mar 09 at 01:53 AM

    Hi mahesh,

    Sometimes, the channel status is not replicated correctly due to cache, could you try to restart the channel and check it again?

    If the issue persists, you can try to the dummy change e.g. add a space on the description of the idoc sender channel, save and activate it so that the cache for the channel will be created again. Then check if the status is OK.

    Best Regards,

    Liz

    Add comment
    10|10000 characters needed characters exceeded

  • Mar 09 at 04:54 PM

    We also experience this behavior, funny enough only on one specific test system. Also I'm not sure if it's the channel or the system that is configured differently or the mentioned cache.

    The only thing I can add is that for us also restarting the channel remedies the problem for a specific time.

    Cheers

    Jens

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    May 02 at 03:20 PM

    Got it fixed by cloning the the InboundRA.

    Add comment
    10|10000 characters needed characters exceeded