Skip to Content
0

Rounding off Issue in Webi Report

Mar 08 at 02:25 PM

80

avatar image

Hello All,

We have Issue with Webi , The value in the webi reporting is rounding off, which we don't wanted in our report, and we have used Format number and keeping decimals didn't work as we wanted.

and the Bex query is showing correctly for , example - measure in the Bex showing 45,777.500 , Webi report is rounding off the value 45,778.000.

Does anyone have solution to this, to get rid of the rounding value and keeping the 3 decimals?

current formula we're using is -

=FormatNumber([measure]);"##,#0.000")

Thanks,

Teena

10 |10000 characters needed characters left characters exceeded

What is the BO version?

0

SAP BusinessObjects BI Platform 4.2 Support Pack 4

0

Koen Hesters any diea?

0

We are on BI 4.1, no experience with 4.2

-> But I guess without formula you have the correct number, but after apllying the formula you don't have it anymore.

maybe it is your forlmula check this out =FormatNumber([measure]);"##,##0.000")

But to be honest I try to set the regional format and language preference to set the format of dates and numbers

check out

https://archive.sap.com/discussions/thread/3381444

0

Hello Koen,

We're getting 45,778 in Webi without formula , we're getting 45,778.000 after applying the formula.

but Bex is showing 45.777,500 - and the expected result is 45,777.500.

Thanks,

Teena

0

Hi does it have a unit or a currency ?

is it a virtual infocube or a standard infocube ?

0

it has the units and it is on the composite provider.

Thanks,

0

Can you check definition for the unit in table T006 please, could be a BW definition

1

Issue has been solved , thanks for your reply Koen ! :)

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Teena Gattu Mar 12 at 10:37 AM
0

Hello Koen,

the table shows as below - no. of decimals set as 0 - do we need to change this to 3 or something - how we change this table ? is it through global settings?

Thanks,
Teena


ymack.png (26.4 kB)
Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi,

you will have to check with your infrastructure guys, it could be these settings are coming from your ERP system. But yueah change that to 3 and it should work.

Grtz

Koen

1

Thanks for your Inputs ! we'll implement and let you know on this.

Thanks,

Teena

1