Skip to Content
0

HANA Express 2.0 SPS2 - Web IDE Che Gateway Time out

Mar 06 at 12:45 PM

296

avatar image

Hi folks,

I am running HANA Express 2.0 on VMware with 24 GB ram ...

I regularly get the following error when trying to run scripts from within the webide:

"Application is starting ..."

"Request failed: Gateway Timeout URI: /che/runner/workspacezmn3yjpzoy7ad3yc/status/1"

Sometimes when I start web ide I get similar che popup errors and eventually have empty projects ...

Apparently there is somewhere a time out occurring ...

Any pointers on where I could configure these ?

I should also note that - although I have a very powerfull laptop - it sometimes takes up to 45 minutes before all XS apps are started ...

Thanks,

Steven

10 |10000 characters needed characters left characters exceeded

Hi, could you please add the versions of HXE (./HDB version) and Web IDE (Help -> about) and when the problem happens?

0
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Marcel Merkle
Mar 07 at 07:26 AM
3

Hi Steven,

this problem, among others, is fixed with the latest Web IDE release. Unfortunately, it is not yet contained in the latest HANA Express version. However, you can download the latest Web IDE release from the SMP and update it manually. To do so

1. Go to the SMP (https://launchpad.support.sap.com/#/softwarecenter/)

2. Go to Support Packages and Patches -> H -> SAP Hana Platform Edition -> SAP Hana Platform Edition 2.0

3. Download the latest release of SAP HANA RUNTIME TOOLS 2.0 and SAP WEB IDE 2

4. Go to the Web IDE release note (https://launchpad.support.sap.com/#/notes/2457320) and download the file sap-xsac-devx.mtaext

5. Install HRTT with "xs install XSACHRTT04_43-70002322.ZIP"

6. Install Web IDE with "xs install XSACSAPWEBIDE02_7-80002257.ZIP -e sap-xsac-devx.mtaext"

Unfortunately, after the update, you have to "re-enable" your development space. For that,

1. Start the "space-enablement-ui"

2. Login with the XSA_ADMIN user

3. Update your development space.

In time the latest Web IDE release will also be included in HANA Express, but up to now it is not clear when the next HANA Express version will be released.

As to your startup performance: The time to get the system up mostly depends on your disk performance. Do you use an SSD or HDD?

Best regards,

Marcel

Show 6 Share
10 |10000 characters needed characters left characters exceeded

You can also now get the upgrade from the Download Manager: https://blogs.sap.com/2018/03/09/upgrading-web-ide-in-hana-express/

0

Thank you both for this answer ... will try to update asap and confirm my findings :-)

0

Hi Marcel,

Missed your remark about the performance ... I am indeed running on a normal HDD as my SDD isn't big enough to host eveything ... having said that ... will see if I can move stuff around and get this particular VM moved into the SDD ... thanks for that remark.

0

Ok I am in troubles now I think ...

I did a couple of actions and somehow my installation doesn't work anymore it seems

  • Figured out I ran the update script before I installed the speciic webide patch
  • Ran the automatic update script which downloaded new tars of hxe and hxexsa
  • Started the upgrade script - this ran for a while and then my whole laptop staled/crashed
  • Cleaned up the SSD and moved my VM installation to the new disk.
  • Started up the vm again
  • Reran the update script which refuses to continue as it could not find XS endpoint
  • Tried to logon in the xs with hxedm and target space SAP
  • Error - connection refused
  • Retart the XSA ... this is running now already forever and nothing seems to happen ...

Any pointers on how I can see whether I am still good or whether I am in deep trouble ?

Thanks,

Steven

0

Think I found the problem ..

The 'daemon.ini' file was probably altered during the upgrade process to

[xscontroller]
instances = 1
disabled = true
hplm_stopped = 1
[xsexecagent]
instances = 1
disabled = true
hplm_stopped = 1
[xsuaaserver]
instances = 1
disabled = true
hplm_stopped = 1

so it never got changed back into active as the process was interrupted.

Did a restart and the xs controller is available now.

Still have an issue that the XSA service is not reachable apparently but will retry the upgrade process to see if that fixes it.

0

Got everything back working and patched the webide using Lucia's blog ...

Also moved the VM to the SSD - which seems to give a huge difference in performance ..

Thanks again ... learned a lot of new stuff going through this painful excercise .. ... :-)

0