Skip to Content
author's profile photo Former Member
Former Member

ODS as data source for the next ODS - can't see the name in the DS list

Hello, experts!

Need your help. I'm trying to use Staging ODS for the transaction data to populate data into next level of ODS - Standard ODS. The problem is that Staging ODS does not appear in the Data Source list for the Standard ODS when I Assign data sources(and would not let me paste the Staging ODS data source name either). I did Replicate data source for the Staging ODS and Generate Export data sources but it did not fix the problem.

Any suggestions?

Thank you.

Alina.

Add a comment
10|10000 characters needed characters exceeded

Related questions

9 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 02:41 PM

    Hi Alina,

    After doing Generate Export Datasource.

    Go to Source systems and go to Datasource overview for your BW system. You should find the datasource 8****** under BW Datasources-> Business Info Warehouse -> Data Marts.

    Regards

    Hemant Khemani

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 02:49 PM

    Hi,

    first generate export DS; then replicate DS.

    Also ensure that you have "show generated ODS objects enabled" in the AWB (menu settings/display generated ODS objects)

    hope this helps....

    Olivier.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 02:48 PM

    Thank you, Hemant.

    I can see my data source with the name 8******** in the list of Source systems but when trying to Assign data sources for the new ODS, this name does not show up in the drop down list and would not let me type it or paste it either.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 03:08 PM

    Thank you, Oliver!

    When I saw your reply I was sure that was the answer - unfortunately after Generate Export and Replicate and changing the setting to Show Generated Objects this data source still does show up in the available DS list. Bummer!

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 03:23 PM

    Hi, Siggi,

    We're in 3.5 - so all objects are in the same release.... drives me crazy

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      your dsource should definitvely show up under MyBWSystem\BW Dsources\ BIW \ Datamarts.

      Do you see the datamart Node?

      Did you replicate dsources for the source system; this is your BW itself?

      Try RSA12; right click ISources and then insert lost nodes and go back to RSA13 right click your current BW source sys and display DSources...

      Another check would be to run RSA2 input 8* and then F4; your generate export dsource should popup there; otherwise the generation of the export DSource failed...

      hope this helps....

      let us know

      Olivier.

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 04:17 PM

    Thanks, Oliver!

    I can see my data source in RSA2 and in MyBWSystem\BW Dsources\ BIW \ Datamarts. That's all good.

    My problem is when I try to Assign Data source for the InfoSource, the dropdown list only shows 50 available entries for the Source System(RSA2 returns 145). Seems to me that the dropdown list does not show all the datasources and i can't change that. I changed the setiings you suggested to show generated ODS but it did not help. Thank You for your help!

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      OK, you're talking about the selection screen "Available datasources" showing only 50 entries right?

      In my system the screen can show more than 900... must be one of your user settings in the gui...

      just under the tab "restrictions" there is a line with an arrow pointing down; click this line to expand the restrictions...

      In the DataSource field enter 8* or 8<ODS_TECH_NAME> in order to see your DSource.

      Otherwise in RSA13 in your Dsources overview, right click it and "assign infosource"; it will also make it...

      hope this helps...

      Olivier.

      Edited by: Olivier Cora on Jul 30, 2008 6:31 PM

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 04:54 PM

    Hi, Olivier,

    When I go to the Restrictions tab and try to find the ds, it does not show up.

    It shows up in RSA2 list and I can see it in DataMarts list for my Source System, but when time comes to assign IS to this DS, it can't be found in the dropdown (or in the Restriction list) and I can't type it in.

    Also, in RSA13 when I right click on the DS, it does not give option of assigning it to IS.

    Thanks a lot for all your help - I hope that you have more tricks up your sleeve to solve it.

    Alina

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      then the DS is already assigned an ISource! You can a + or - sign on its right; what do you see?

      If it is already assigned then right click and "change TRules" in order to see the corresponding Isource.

      hope this helps...

      Olivier.

  • author's profile photo Former Member
    Former Member
    Posted on Jul 30, 2008 at 05:29 PM

    Hi, Olivier,

    You are right - the ds has + and has IS assignment, but in the IS field it has it's own DS name and when I try to change transfer_Structure/Transfer_Rules I need to choose data source for the source system and AGAIN I don't see my data source there. Sorry if I sound confused - it's because I'm...

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Aug 13, 2008 at 08:28 PM

    Resolution: when generate export datasource, system generates native infosource (staring with 8) which is assigned to you datasource. If you want to create your own IS go to the native (in Unassigned) delete communication structure and then your data source will show up in the drop down list of available data sources

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.