Skip to Content
0
Former Member
Jul 30, 2008 at 03:42 AM

saprouter service cannot be started

422 Views

Hi friends

I'm encountering an error of starting saprouter service on win32 platform, like 'The SAPRouter service terminated unexpectedly. It has done this 1 time(s).' in eventviewer.

The physical server is window 2003 SP2 32bit, saprouter version is 700 and I also tried 640 but got the same error. The installation command of saprouter I used is 'ntscmgr install SAPRouter -b c:\saprouter\saprouter.exe -p "service -r -R c:\saprouter\ROUTTAB -C 2000 -Y 0 -D" '.

Additional info in the file dev_rout as below:

-


trc file: "dev_rout", trc level: 1, release: "700"

-


Tue Jul 29 22:32:55 2008

SAP Network Interface Router, Version 38.8

command line arg 0: d:\saprouter\saprouter.exe

command line arg 1: -r

command line arg 2: -R

command line arg 3: d:\saprouter\ROUTTAB

command line arg 4: -C

command line arg 5: 2000

command line arg 6: -Y

command line arg 7: 0

command line arg 8: -D

main: pid = 5900, ppid = 0, port = 3299, parent port = 0 (0 = parent is not a saprouter)

      • ERROR => fopen 'd:\saprouter\ROUTTAB' (2: No such file or directory) [nirout.cpp 7609]

      **LOG Q0I=> NiRRouttab: fopen (2: ENOENT: No such file or directory OR: The system cannot find the file specified. ) [nirout.cpp 7611]

      cannot open 'd:\saprouter\ROUTTAB': all routing disabled!!!

      Could not open permission table

      So could you please help me troubleshooting this issue?

      Thanks and best regards

      Effan