Skip to Content
0
Former Member
Jul 29, 2008 at 02:31 PM

Auto-generated WDP content missing

20 Views

Hello all,

I've been working on a Web Dynpro project since last week, consisting of a single DC. Everything worked fine, but since last Friday afternoon, I'm getting a build error. I've tried resolving it, but have been unsuccessful so far.

The Web Dynpro DC uses the Message Pool. The error as specified in the editor as: "The import nl.phoqus.ao.wdp.IMessageAOApp could not be resolved."

Apparently this is a class that gets generated automatically by the NWDS; the format is generally IMessage<CompName>.java, with CompName the name of the component controller (in this case "AOApp").

After confirming that the specified class file was, in fact, nowhere to be found on the filesystem, I tried the browsing the DTR. Apparently, it's vanished there, too. In fact, syncing to a date -waaay- in the past, several months ago, when the project was guaranteed to be fine, didn't work either; the entire src\nl\phoqus\ao\wdp\ directory seems to be missing.

As a sanity check (I really needed one at this point), I pulled a copy of the deployed .EAR file as it was running on our NWD machine over to my local machine; the /wdp/ directory is there in that particular archive's src archive.

Is our DTR broken? Did I screw up somewhere? Any advice would be appreciated.

Thanks,

Kars.