Skip to Content
author's profile photo Former Member
Former Member

Error in creating implicit enhancement

Hi Experts,

I want to create an implicit enhancement in a standard program. I went to Edit -> show implicit enhancements

and right clicked at the yellow lines and clicked create .

it asked for the enhancement name. after giving name and pressed ok , it is showing error 'Error in creating enhancement'

why is this error coming?

Thanks in advance

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jul 29, 2008 at 10:47 AM

    Hi

    I hope this helps you

    error while creating Client Proxy from SE80

    regards

    Pavan

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 29, 2008 at 10:57 AM

    hi

    check wheather that enehancemant is being already is used or being implimented .

    if it is and if that project is in Z name space u can impliment ur requirment in that project anf if it is not then frist deactivate it and create new one and impliment that enhancemant in new project.

    Cheers

    Snehi

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      hi vijaya

      well let me take an example

      suppose u r requiremwnt is to disable an field in an XYZ transaction

      And let the Enhancemant for this

      XYZ0001P.

      now when u go to CMOD and create

      an project as

      Z_xyz

      and when u go to enhancement Assingment

      here u give the enhance ment number which in our case is

      XYZ0001P

      now if u save it . It will not get saved and show and error message which says

      this enhancemanet is alreay is being used

      in another project

      this is because u can one enhancement can only be used in one project only .

      Hope it have cleared ur problem .

      Cheers

      Snehi

  • author's profile photo Former Member
    Former Member
    Posted on Jul 31, 2008 at 09:40 AM

    Hi,

    check the below steps when you create a implicit enhancement.

    1. Go the currect program name.

    2. click 'Enhance Source Code' (Shift+F4) button in the toolbar.

    3. Go to Edit->enahcement operation->show implicit enhancement

    4. place the cursor where you want to create the implementation.

    5. Go to Edit->enahcement operation->Create

    6. It will show the popup here click the 'Declare' button.

    7. Here give the Implementation name, des, and composit enhan. implementation.

    6. select the implementaion name when you entered in the 7.

    Search it in SDN you will get lot of info about enhancement spot.

    Regards,

    Boobalan S

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.