Skip to Content

Agentry application issue - how to disable PerformCompile in Agentry.ini

Mar 06 at 02:06 PM


avatar image
Former Member

Hi experts,

I'm experiencing a strange bug after deploying a new version of an Agentry application.

SMP server: on Windows

Application: Customized version of Inventory Manager 4.2

Error in events.log:

com.syclo.agentry.internal.CompilationException: F:\SAP\MobilePlatform3\Server\.\ error: package com.syclo.agentry does not exist

It seems that the root cause is an option in the Agentry.ini:


There is no possibility in the Admin GUI to disable this option (set PerformCompile to false). According to the documentation this parameter is deprecated, but another application running on the same SMP server is working correctly and there this option is "false".

This behaviour occurs in development and production environment.

Manually changing this option directly in the file system (on development server) has no effect, after a restart this option is activated again.

I would be happy about any hint.

Regards, Christian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Resmi Sadasivan
Mar 07 at 03:44 PM

Hi Christian,

Another option would be, change the Agenttry.ini, redeploy the application, through the cockpit, restart the agentry instance (don't restart the SMP server), the changes would commit to the underlying database.



10 |10000 characters needed characters left characters exceeded