Skip to Content
avatar image
Former Member

I cannot link to Excel Workbook (Office and Excel 2010)

I get the attached error when I attempt to link to an Excel Workbook (which I "converted" from an Excel 97 file using Excel 2010). How do I proceed? I'm trying to link Crystal 2016 with excel files that have more lines than Excel 97 supported.10-27-2016-9-49-04-am.png

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Oct 27, 2016 at 09:18 PM

    You need to configure a 32-bit ODBC connection to the workbook in order to use it in Crystal 2016.

    -Dell

    Add comment
    10|10000 characters needed characters exceeded

    • Hi Brian,

      There are two ways to connect to Excel. One is the direct connection like you tried originally. This only works with older 32 bit versions of Excel. If you have 64 bit Office then the direct connection won't work because Crystal is still 32 bit only.

      The second option that will work is, as Dell mentioned, going through ODBC. Windows comes with a 32 bit and 64 bit version of ODBC, so in this case, for Crystal to work you will need to use the 32 bit version. Follow Dell's instructions as described to set up the ODBC on your machine. Then in Crystal Reports go into the Database Expert, open the Create New Connection folder, select ODBC (RDO) folder and you should see the ODBC connection you created for your Excel file.

      Good luck,

      Brian

  • avatar image
    Former Member
    Nov 03, 2016 at 05:56 PM

    Do you have any instructions or examples on how to do so? Thanks for your reply.

    Add comment
    10|10000 characters needed characters exceeded

  • Nov 03, 2016 at 06:17 PM

    Run C:\Windows\SysWOW64\odbcad32.exe. Create a DSN using the appropriate Microsoft Excel driver for the type of file that you're connecting to and connecting to the file you need. If this report will be run from an application on a server and not your local drive, you'll need to use a UNC path to point to the file when you configure this on the server. Use the ODBC connection in your report.

    -Dell

    Add comment
    10|10000 characters needed characters exceeded