Skip to Content
0

Unable to retrieve data from Failed data Repository in Information Steward for Views

Oct 27, 2016 at 06:23 PM

208

avatar image

Hi Experts,

In Information Steward we have set up Failed Data Repository to get failed records more than 500 as IS has a limitation of 500 failed records. When we are trying to view the failed data by clicking on 'more failed data' button we are getting 'Failed data processing is not complete ' error when i am binding rules to view.

When i am binding the same rules to Tables i am able to get more failed data from Failed Data Repository in Information steward. Please let us know if there is any resolution for this.

Our IS version is 4.2 SP06 and failed data repository is in Oracle 12c.

Regards

Ajukar S

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Aasavari Bhave
Oct 28, 2016 at 12:26 PM
0

check ICC. ApplicationService log to check the underlying error. You should find the sql IS issues to failed data data in order to retrieve data. There may be java related error.

Is the issue specific to a view or happens with every view? Is it possible for you to create a new view - bind it to rule and test ?

Share
10 |10000 characters needed characters left characters exceeded
MUSTAFA DADAWALLA Oct 28, 2016 at 06:53 PM
0

Aasavari - Where is this log located on Windows OS ? having same issue... Thanks!

Mustafa

Share
10 |10000 characters needed characters left characters exceeded
AJUKAR S Oct 30, 2016 at 02:50 PM
0

We have created failed data repository in Oracle (12c) to capture data that failed rules. Initially we were able to retrieve ‘more failed data’ from Repository. But after transporting the project to another environment we are getting ‘Failed data processing cannot be completed’ error when we click on ‘more failed data’ button from IS.

We have tried the following steps

  • 1)Copying the view, deleting the task, unbinding the rule, deleting the view, bind rule to new view and recreate the task.
  • 2)Deleting the project and reimporting the project.
  • 3)Deleting and creating a new Failed Record Connection
  • 4)Creation of a new Failed Record Connection using a different Repo User.
  • 5)Deleting all the _FD and _FR tables from the repository with help from DBA team.
  • 6)Deleting the project and importing the Rules only to project without any connections. After that reimported tables and created views and bind the rules to View.
  • 7)Facing the same error in development and Quality environments.
  • 8)We have checked the logs but could not find any further details on the error

But still getting the same error ‘Failed data processing cannot be completed’ and I have attached our FDR connection details and Error screenshot.

Share
10 |10000 characters needed characters left characters exceeded
Aasavari Bhave
Nov 01, 2016 at 06:38 PM
0

You are more likely to see this error when projects move from one env to another due to 1. possible corruption in failed data database connection 2. data profiling connection corruption. Assuming rule tasks run successfully - check on the failed data database is the data is being collected. If correct data is being collected - but you get error in view more failed data - ICC.ApplicationService log should give some error most likely java stack trace in InformationSteward\MM\log folder.

Beginning In IS 4.2 SP7 a new utility is added in CMC > Information Steward Application > Utilities to clean failed data database.

You ma want to open a support incidence with SAP support for further troubleshooting. Ideally creating a new failed data database connection should work.

Share
10 |10000 characters needed characters left characters exceeded