Skip to Content
avatar image
Former Member

Logical file name or logical path name incorrectly defined

Hi Expert,

We are doing archiving. Delete job is scheduled and released ok, but it is cancelled in running, error message title as above.

Our technical setting in 'data archiving customizing' for the object leave the field 'Logic file name' blank. The field 'Content repository' is also blank.

Can someone give a hint on that? The exact erro message pasted below.

Logical file name or logical path name incorrectly defined

Message no. BA282

Diagnosis

When generating a file name for an archive file that is to be created, the system determined that the logical file name ARCHIVE_DATA_FILE or the logical path name ARCHIVE_GLOBAL_PATH was defined incorrectly.

System response

Despite the incorrect definition, a file name was generated. The system will now continue to create a new archive file. Errors may occur when the archive file is accessed at a later date, or when the file name is to be displayed.

Procedure

When assigning a physical file name to the logical file name, no part of the directory name may be used.

When assigning a physical directory to the logical file name, only component parts of the directory name may be used. In particular, file endings, such as 'ARCHIVE' are to be assigned to the physical file name.

Use these criteria to check the definition of logical file name ARCHIVE_DATA_FILE and logical path name ARCHIVE_GLOBAL_PATH.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 28, 2008 at 06:01 PM

    Hello,

    I believe you are getting this error because the logical file name parameter in your customizing settings is blank. Since the parameter is blank, the delete job does not no where to find the archive file that was written.

    You need to assign an archive object a logical file name that has the appropriate logical file path defined of where you want the archive files to be written to. To set up this configuration, use transaction FILE to first define the logical file path definition, and then the logical file name definition.

    I hope this helps.

    Best Regards,

    Karin Tillotson

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 29, 2008 at 09:58 AM

    hi,

    error probably caused by this one

    Syntax group WINDOWS NT Microsoft Windows NT

    Physical path C:\TEMP\<FILENAME>.ARCHIVING

    to correct it, please set

    Syntax group WINDOWS NT Microsoft Windows NT

    Physical path C:\TEMP\<FILENAME>

    (without .ARCHIVING) because this is defining physical path not defining a archiving file.

    You don't need to define archive file here as you have define archiving file correctly on your other statement :

    Physical file <PARAM_1>_<PARAM_3>_<DATE>_<TIME>_<PARAM_2>.ARCHIVE

    hope it help you,

    rgds,

    Alfonsus Guritno

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi

      The suggestion is correct. before the change, job log is as below:

      29.07.2008 14:19:44 Job started

      29.07.2008 14:19:44 Step 001 started (program RCPREWR1, variant YRTG2, user ID ...)

      29.07.2008 14:19:44 Archiving session 000012 is being created

      29.07.2008 14:19:45 Logical file name or logical path name incorrectly defined

      29.07.2008 14:19:45 Operating system message: No such file or directory

      29.07.2008 14:19:45 Archive file C:\TEMP\PP_PP_PLAN_20080729_141945_0.ARCHIVE.ARCHI cannot be opened for write program

      29.07.2008 14:19:45 Job cancelled after system exception ERROR_MESSAGE

      After the change, job log is changed as below:

      29.07.2008 18:14:14 Job started

      29.07.2008 18:14:14 Step 001 started (program RCPREWR1, variant YRTG3, user ID ...)

      29.07.2008 18:14:14 Archiving session 000013 is being created

      29.07.2008 18:14:15 Operating system message: No such file or directory

      29.07.2008 18:14:15 Archive file C:\TEMP\PP_PP_PLAN_20080729_181415_0.ARCHIVE cannot be opened for write progra

      29.07.2008 18:14:15 Job cancelled after system exception ERROR_MESSAGE

      But the job is still cancelled, because of the message: Operating system message: No such file or directory

      Message no. BA161

      Any further clue?

      TIA

  • avatar image
    Former Member
    Jul 30, 2008 at 02:52 AM

    hi,

    please make sure that directory C:\TEMP\ is exist on your system, and this directory is accessibble on full control mode (read-write) by your <SID>adm user or by "everyone" if you permit it.

    hope it solve your problem 😊

    rgds,

    Alfonsus Guritno

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi,

      The folder is there, but it is 'read-only'. But we couldn't remove the folder 'read-only' attribute. Once you untick 'read-only', apply, and check the property again, it is ticked 'read-only'. The user assigned to this folder has 'full' access.

      We are using Windows Vista. I believe this needs some Windows Vista trick, other than SAP knowledge. Is there any chance someone in this forum knows the trick?

      TIA

  • avatar image
    Former Member
    Jul 29, 2008 at 04:52 AM

    hi,

    follow this steps :

    - transaction SARA

    - enter authorization objects, eg SD_VBAK

    - hit button CUSTOMIZING

    - Archiving Object-Specific Customizing: execute Technical Setting

    - field Logical File Name enter or select ARCHIVE_DATA_FILE

    - leave CONTENT REPOSITORY as blank if you are not using 3rd party for storing (eg. IBM Tivoli)

    - back to customizing

    - from Basis Customizing, execute : Cross-Client File Names/Paths

    - on Logical FIle Path Definition, highlight (select) ARCHIVE_GLOBAL_PATH on the right pane

    - double click on the Assignment of Physical Paths to Logical Path on the left pane

    - double click on OS used, eg. UNIX, define Physical Path where archive file (on WRITE process) will be stored

    - save changes made

    - double click Logical File Definition, Cross Client on the left pane

    - double click ARCHIVE_DATA_FILE on the right pane

    - make sure that logical path is already set to ARCHIVE_GLOBAL_PATH

    - save changes made

    this setting also can be done using transaction FILE

    we have experienced on this case using SAP standard archiving (SARA, SARI) and everything is fine with this setting above.

    hope it help you.

    rgds,

    Alfonsus Guritno

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Alfonsus ,

      Thanks for your detail steps. But it is still showing same error. Below is my setting:

      For step: Cross-Client File Names/Paths our setting is:

      Logical path ARCHIVE_GLOBAL_PATH

      Name Global path for archiving files

      -


      Syntax group WINDOWS NT Microsoft Windows NT

      Physical path C:\TEMP\<FILENAME>.ARCHIVING

      For Logical File Definition, Cross Client our setting is:

      Logical file ARCHIVE_DATA_FILE

      Name Archive file for archiving application data

      Physical file <PARAM_1>_<PARAM_3>_<DATE>_<TIME>_<PARAM_2>.ARCHIVE

      Data format

      Applicat.area BC

      Logical path ARCHIVE_GLOBAL_PATH

      We did a try after finishing the change. But on 'Write' process in SARA, job cancellled and shows same message as our initial problem description.

      Any other clue?

      TIA

  • avatar image
    Former Member
    Jul 31, 2008 at 02:12 AM

    hi,

    well if it is Windows Vista issue, I think it is out of scope of this SAP forum 😊

    but this link may help you :

    [http://thevistaforums.com/index.php?showtopic=14979πd=99477&st=0&]

    [http://www.vistax64.com/tutorials/107890-read-only-file-folder-attribute.html]

    rgds,

    Alfonsus Guritno

    Add comment
    10|10000 characters needed characters exceeded