Skip to Content
3

[Bug] Can't upload more than two images / no user feedback

Mar 03 at 02:08 PM

117

avatar image

[rant alert]

I so hate this platform!

As is evidenced by the timestamps on my screenshots and the actual posting time of my comments on this post, it took me over 23 minutes to post three short lines of text and three screen grabs.

Problem 1: I can paste images, which sometimes, if the wind is right, may or may not appear in the editing box (hurdle one cleared!), and sometimes, if it's not raining, may or may not appear in the post after submission. On this occasion I just got my text sans images after saving. So I saved my screenshots and tried it again via the upload image function.

Problem 2: The submit button didn't work. It just kinda gave the impression it got clicked. Nothing else happened. Refreshed, and tried to post again. Logout/login, same thing. Tried different browsers, same everywhere. Eventually I deleted one image and voila, it posted!

Problem 3: Why was there no user feedback? Asinine two image limit (*) aside, if a system doesn't function I expect to be informed. Not spend the next 21 minutes guessing and getting frustrated.

We're in 2018, why can't we get the basics working? In many platforms, e.g. Jira, pasting an image just works. Has done for years. And what's with the apparent randomness? (it probably has some specific circumstances, but I really don't have the time to play support and figure it out). Either make it work consistently or disable it until it does.

Did I mention I hate this platform? We just want the basics. SDN version 1 did a better job, simply because: It. Just. Worked.

(*) - Why is the two image limit senseless? There used to be a size limit where it would complain "You can't upload more than 2MB" or whatever. It is common practice to describe a sequence of events with screenshots. So if that was a deliberate change so that we cannot post three 40kb images yet can still include two 1MB images then that's just cockamamy.

10 |10000 characters needed characters left characters exceeded

Hi Mike Pokraka ,

I apologize for this experience. What browser were you using? Knowing this will help me follow-up with IT. FF?

Thanks a lot,

Moshe

0

Hi Moshe,

Thanks for getting back to me, I've had these and similar issues on Chrome, FF, Safari on Windows and Mac for some time. The above case in particular I tried with the most recent Safari & FF on MacOS.

No need for you to apologise, this is not personal and I appreciate the work you guys are trying to do. The rant is not specifically about this issue, but about the awful UX in general and the slow progress and apparent focus on things that are not so important to the end users (us). I am really still baffled why we moved to this platform in first place.

Regards,

Mike

0

Hi, Mike:

Just to clarify: Are you saying you can't put more than 2 images into a question? Because it was my understanding that this changed: https://influence.sap.com/sap/ino/#/idea/137754/?section=sectionComments

Also, when it comes to pasting images, I thought this was a feature request, not a bug: https://influence.sap.com/sap/ino/#/idea/140754

The issue with the submit button does seem like a bug. But for the others, I'm trying to confirm if we're looking at bugs or feature requests. Your response could help us make a better determination.

Best regards,

--Jerry

0

Hi Jerry,

Definitely bugs in my book, all of them.

I can do a standard Mac screen grab and paste it in here with <cmd>V (Safari) and it appears in the edit box. If I submit, it disappears ==> bug.

I've had mixed results with different software on client machines, occasionally it works, many times it won't even paste. Very inconsistent behaviour ==> bug.

The submit button was unresponsive until I removed one of the images ==> bug.

Thanks & regards,

Mike

1
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Vadim Kalinin Mar 04 at 07:17 AM
1

Old issue for picture cut and paste: https://blogs.sap.com/2017/05/19/answering-community-questions-list-of-issues/

Still no reaction!

I have spend hours to save images on local PC then uploading to SAP.com.

Show 4 Share
10 |10000 characters needed characters left characters exceeded

Yes, I know some of this is old. I wanted to hilight, with a practical example, what a moderately experienced user sometimes has to go through to do something that should take 1 minute (literally!). Let alone occasional / newbie users.

If you include the dev/implementation time, this "upgrade" must have been going for well over two years. What message does this send out about a supposedly cutting edge world class software company?

1

Message is simple: SAP is NOT listening to Community contributors :(

0
Hi Vadim Kalinin ,

Sorry about that but please rest assure that we're still monitoring the issues you reported in your original blog. We will soon post an update there regarding current status.

Regards,

Moshe

0

The original bug report:

Unable to copy/paste pictures in the comment/answer with FireFox 50.0

https://answers.sap.com/questions/68104/unable-to-insert-pictures-in-the-comment.html

was posted: Nov 23, 2016 at 10:30 AM

More than one year ago (16 months)!


0
Lucas Costa Mar 04 at 09:41 PM
0

The issues around upload/pasting images leads not just to a waste of time but also to the extremely annoying images not showing in the thread...

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Actually it's a different issue: "Insert File" button has to reject image files. Image files has to be attached only using "Insert Image".

0