Skip to Content
0

NetWeaver ABAP Developer edition - Cannot deploy to Azure

Mar 03 at 12:45 PM

95

avatar image

I was trying to set up a new ABAP system, but cannot deploy any Cloud Appliance Library (CAL) instances to Azure.

I have both Azure and Amazon AWS accounts, both registered with CAL. I was able to deploy instances to both in the past, and still have a working 7.50 instance on Azure that I can control from CAL.

My Azure account shows as active and I can configure it, but when I want to create any instance, I only see AWS in the account drop down. Is this an issue with CAL, or Azure, or my accounts, because it worked in the past?

I also asked this as a comment in the blog SAP AS ABAP 750 SP01 Developer Edition on SAP Cloud Appliance Library, but no response so am asking agin.

I have in the meantime verified that all my account settings are valid, have used the "Test Connection" feature under account management (response: "The connection with your subscription in Microsoft Azure is valid."), and as I said I have an Azure instance that I can manage.

When I check the CAL access in Azure, I can see the management certificate, valid until 23/04/2033, so everything looks right either end.

10 |10000 characters needed characters left characters exceeded

Working Azure instance in CAL:

Yet when I try to create a new instance:

0

...and because this platform doesn't like to accept more than two screenshots, here's my testing a separate post:

0
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Aleksandar Raychev
Mar 06 at 11:47 PM
0

Hello

Azure Classic is not supported anymore, you have to create an AzureRM account if you want to spin up a solution instance.

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Aleksandar,

Thanks, that got it working!

There are a couple of issues / suggestions with this setup:

1. There is no information anywhere about this, neither messages or mentioned in the documentation.

2. The 'Account' is a CAL thing, I simply created a new "CAL Account" pointing to the same Azure subscription/account to get it to work.

3. Both classic and RM are deployed into resource groups created by CAL. So now I have resource groups for classic and RM instances all created by CAL living happily side by side in my Azure account (see pic below).

Therefore the restriction seems quite arbitrary and seems more like a bug to me? Maybe that's why there are no messages or documentation on it?

Nevertheless, it's working fine now. Thanks again for your help,

Mike

capture.jpg (32.7 kB)
0
Aleksandar Raychev
Mar 03 at 12:50 PM
0

Hello, could you send the link to the solution? Is it available in MS Azure as a provider in general?

When you list all the Golden solutions, you can check in the column "Available In" in which provider the solutions exist

https://cal.sap.com/catalog#/solutions

Show 3 Share
10 |10000 characters needed characters left characters exceeded
0

Hello, are the solutions activated in MS Azure account?

0
Aleksandar Raychev

Thanks for getting back to me, no I don't get a choice here either. If I click activate it shows the message

And then the related accounts show my AWS account:

The selection under "Add" is empty, my Azure account is shown everywhere else on CAL, but not here. The behaviour is as if the instance doesn't support Azure.

0
Aleksandar Raychev
Mar 03 at 04:26 PM
0
Show 4 Share
10 |10000 characters needed characters left characters exceeded

This exactly documents the bit that does not work as expected:

"From the list of available accounts for the solution, you have to select the accounts for which you want to activate the solution and choose OK."

I get no list --> it behaves as if my Azure account is not supported for the solution. So back to my question, why does it not like my Azure account for any recent instances? At least I'm beginning to suspect it might be my account or the fact that I've got both Azure and AWS accounts.

0

Hello, what is your account id (in the account details you may get into the URL)

Also, you have to open the window for Activating into account. You do not see any other accounts there?

Could you send us some screenshots of account, solution activations, etc.

1
Aleksandar Raychev

Hi Aleksandar,

Thanks for looking into this. I already added screenshots in my comments, will send account details privately. I don't get any choice for activating into an account, it just picks Amazon.

I have created a few instances over the years, so I am familiar with the process. Just oddly now it no longer recognizes Azure for new instances. I now only have the one instance I want to keep until I have my new one:

Thanks,

Mike

capture.jpg (29.0 kB)
0
Aleksandar Raychev

Hi Aleksandar,

Thanks for looking into this. I tried to send my account details via direct message, but this platform won't let me message someone that hasn't contacted me or follows me. If you have insider access and can send me a message I can reply with my account ID.

I already added screenshots in the comments. Azure is simply not available for anything new.

When I activate a solution I get no selection or popup, just a hover-up message that says it has been activated in Azure:

Both accounts are active, I've done this a few times before and have a successful NetWeaver developer instance running on Azure so have no idea what I might be doing wrong:

Thanks,

Mike

capture.jpg (29.0 kB)
capture-2.jpg (16.9 kB)
0
Aleksandar Raychev
Mar 06 at 05:37 PM
0

Hello, could you go to the Solutions tab > Then find the additional Icon and Click Manage Accounts.

Please, see the screenshots:

Then from the field for accounts you need to find your Azure account.

and select it...

Let me know if you still have troubles.

Thanks

Aleksandar


1.png (6.7 kB)
2.png (3.8 kB)
3.png (16.5 kB)
Show 1 Share
10 |10000 characters needed characters left characters exceeded

Been there, it doesn't exist, I get an empty list :-(

capture.jpg (41.8 kB)
0