Skip to Content
0

sap b1 MRP : Recoomendation : the reason for approval field can not be empty

Mar 02 at 12:57 PM

53

avatar image
Former Member

HI

I have bag: "The reason for approval field can not be empty"

in MRP recommendation

when I try to generate an PO

why ?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Nagarajan K Mar 03 at 01:40 AM
0

Hi,

Stop if any add on running and then try.

Regards,

Nagarajan

Share
10 |10000 characters needed characters left characters exceeded
DIEGO LOTHER Mar 02 at 01:37 PM
0

Hi Bogumil,

It seems that this is not a standard rule of SAP Business One, it seems that is some rule that someone added on transaction notification of your database.

If this is a rule in your transaction notification, you can fill this field or you can rewrite your transaction to suits your purpose.

Best Regards,

Diego Lother

Show 5 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Diegie

Tx for answer.

In General setting i set off : enabled Trans. Notif.. proc and i still see this error below. :(

So i have Approval procedures in PO , but all I turned off.

Maybe in Order recom... i can fill some field too ?

I don't see any.

0

Hi Bogumil,

What version of SAP Business One are you using? As I know, it's not possible to deactivate Transaction notification by SAP Business One application.

Regarding the fields, it seems a user defined field in the PO.

Are you trying to perform this action by SAP Business One client or DI API?

Best Regards,

Diego Lother

0

I saw the option that you mentioned, but there is no information about this on SAP B1 help. Then I'm not sure how it this option works.

Look this thread:

https://archive.sap.com/discussions/thread/3868841

It seems that this option not disable the transaction.

Best Regards,

Diego Lother

0
Former Member
Former Member

SAP B1 9.2 PL 08

I REM-oved all in Transact Notify in MS SQL and.... still the same problem.

My recommendation generate PO and i can't set any properties in this time.

I don't know what can i do

0

Hi Bogumil,

I am just sharing some thoughts here:

  1. As mentioned in the thread/3868841 that brought up by Diego, after you enable/disable the TN, you may have to sign out and sign in to the system to see the change.
  2. Is there actually such a field called "Reason for approval" in the PO?
  3. Have you also checked the stored procedure SBO_SP_PostTransactionNotice?

Cheers,

Jimmy

0