Skip to Content
0

SAP Hybris Commerce 6.4 via CAL - Unable to access URLs

Mar 01 at 06:18 AM

185

avatar image

We have activated a trial edition of SAP Hybris Commerce 6.4 instance via CAL on AWS. However, post activation, we are unable to access the following URLs referred in the Getting Started Guide, and get a HTTP 404 error. (Have followed the steps suggested in adding an entry to the local system hosts file with the public IP of the server, so the IP resolves to vhcalhybris.dummy.nodomain).

Hybris Commerce Backoffice: https://vhcalhybris.dummy.nodomain:9002/backoffice/

Hybris Administration Console: https://vhcalhybris.dummy.nodomain:9002/hac/

The system itself has come up fine without any errors on CAL - have also attempted restarting Hybris and Data Hub services but the HTTP 404 error isn't resolved.

I also see another Q by a different user at this link highlighting the same issue - https://answers.sap.com/questions/441256/sap-cloud-application-library-hybris-commerce-64.html

Can someone help please?

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Rakesh Tripathi Mar 01 at 06:35 PM
1

I have worked around this issue in the following manner, if you want to try this out:

(1) Stop Hybris services as shown in the Getting Started Guide.

(2) Establish a ssh session to the server as root, switch to hdbadm and invoke hdbsql and attempt to logon as HYBRISADM. The password for this database user is stored the file /cal/plugins/hyc/6.4/hybris/config/local.properties (which is Appl1ance). When you try to logon it can be seen that this password is expired and the database expects a new password. Provide the new password or HYBRISADM.

(3) Backup the file /cal/plugins/hyc/6.4/hybris/config/local.properties

(4) Update the "Database Connection" section of the file /cal/plugins/hyc/6.4/hybris/config/local.properties as follows, replacing localhost with the private IP of the server for the "db.url" parameter, and the new password for HYBRISADM for the "db.password" parameter.

#Database Connection

db.url=jdbc:sap://<private IP>:30015/?reconnect=true

db.driver=com.sap.db.jdbc.Driver

db.username=HYBRISADM

db.password=<new password>

hanadb.storage.columnbased=true

(5) Establish a new ssh session to the server as root, switch to hybris, and navigate to /cal/plugins/hyc/6.4/hybris/platform, and issue the following commands to start Hybris services:

$. ./setantenv.sh

$nohup ./hybrisserver.sh &

After starting the services as above, the following URLs - https://vhcalhybris.dummy.nodomain:9002/hac , https://vhcalhybris.dummy.nodomain:9002/backoffice, and the storefront URLs provided in the CAL Getting Started Guide - for this solution works fine for me. (You'll need to map the public IP of the server in the local desktop's "hosts" file for the above URLs to resolve though, as detailed in the Getting Started Guide).

Hope this helps.

Rakesh Tripathi

Share
10 |10000 characters needed characters left characters exceeded