Skip to Content
0

Is there a way to update layout editor on SAP Web IDE Personal Edition?

Mar 02 at 10:16 AM

86

avatar image

After solving the issue with the adding new versions of SAPUI5 to WEB IDE Personal Edition, I have faced a new problem there.

Your project is using SAPUI5 version 1.48.9 which is not supported by the layout editor. It will be displayed using SAPUI5 version 1.44.12 instead.

I know I can get rid of this message by changing the version in neo-app.json file.

But although the message is gone then I can't use the layout editor anymore.

So is there a way to update layout editor just like the SAPUI5 versions

? (https://answers.sap.com/questions/448102/can-i-add-new-sapui5-versions-to-sap-web-ide-perso.html)

Cheers
Łukasz

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

3 Answers

Best Answer
Elina Visoki
Mar 04 at 12:36 PM
0

Hi,

After adding new SAPUI5 versions to personal edition, you can use them in the code completion and in the preview. The layout editor is not being updated.

We recommend to use the cloud version of Web IDE that is updated all the time.

Best regards,

Elina

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Elina, I was expecting maybe a workaround how to do it, especially that Personal Edition is not updated so often. At the end this is "just" website ;-)

Thanks anyway for clarifying.

0
Kevin Bates
Mar 02 at 06:03 PM
1

I would not expect SAP Web IDE to be compatible with a new Major version only minor versions. Example, I would expect the same to work if you upgraded from 1.44.12 to 1.44.32, but not 1.48.x 1.50.x or 1.52.x.

-kevin

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Thanks Kevin.

0
Michal Keidar
Mar 04 at 08:31 AM
0

Hofit Koren Amiram Wingarten - Please assist.

Thanks,
Michal.

Share
10 |10000 characters needed characters left characters exceeded