Skip to Content
0

Crystal Cross tab suppress total and show zero fields

Mar 01 at 06:14 PM

40

avatar image

Experts,

I'm consolidating financials in Crystal across 2 DB's (A & B) and using Cross Tab in Crystal works well.

Question 1: I see that there is a total of some sort under the DB name column. But I do not know where this comes from, it is not the Sum of the Balance... How can I suppress this total? It seems it is something Cross Tab is doing automatically, I cannot select that field to suppress.

Question 2: I do not see all the Account Segments in the rows - the ones with 0 values does not show. I need all to show even if it is $0.

Your assistance will be appreciated,

Marli

3.png (30.4 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Marli Schutte Mar 05 at 04:48 PM
0

I was able to solve the extra amount and wrong Total field with the Cross Tab Expert > Cross Tab > Cross Tab Group Options > Others: "Discard all others"

Thanks for your assistance.


4.png (131.7 kB)
Share
10 |10000 characters needed characters left characters exceeded
Abhilash Kumar
Mar 01 at 07:58 PM
1

Hi Marli,

Do you have Account Segments with NULL values? If yes, then that's what the first row is.

To show all rows, go to the Crosstab Expert > Customize Style and make sure "Suppress Empty Row" and "Suppress Empty Columns" is unchecked.

-Abhilash

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Abhilash,

Thanks for the feedback. I do not totally understand the Account Segment with NULL values, it this not mandatory to fill in?

I checked and I do have the "Suppress Empty Row" and "Suppress Empty Columns" unchecked. I still get that extra amount and a wrong total...

1.png (162.2 kB)
0

Abhilash,

When I did the Sorting like you mentioned in the other Tread, it now displays this value as "Other", which I have not created in the Sorting on the Cross Tab > Specified order.

2.png (50.6 kB)
0