Skip to Content
0

Black stripes on pdf when created by Crystal Report iOS

Mar 01 at 03:18 PM

139

avatar image

Hi,
A mutual customer of ours has an issue with pdf's created by Crystal reports when opened on a iOS device, like iPhone or iPad.
When the customer opens the pdf on his device, the pdf contains a lot of black stripes, rendering the text unreadable. (see image)Pdf's created by other programs cause no issue.

Are you familiar with this issue? Is there anything that can be done about it?

UPDATE (2/03/2018): We have tried to let Crystal reports generate a hyperlink in a pdf, and the same error occured.

With on iOS version 9.3.5 the reports look fine.
But with the latest iOS (above 11.2.5) it looks like the example above.

Thank you in advance

welda.png (108.9 kB)
iOS | pdf
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

Best Answer
Don Williams
Jun 04 at 02:01 PM
0

See KBA for update:

150196 / 2018 Black stripes in images when exported to PDF on IOS

KBA - 2623112 - Black stripes in images when exported to PDF format and viewed on an IOS device

Don

- SAP BusinessObjects Business Intelligence platform 4.2 SP_COR

- SAP BusinessObjects Business Intelligence platform 4.1 SP_COR

- Crystal Reports 2016 – Support Pack 06
- Crystal Reports 2013 – Support Pack 10

- Crystal Reports for Visual Studio SP 23

Share
10 |10000 characters needed characters left characters exceeded
Allan Harte Mar 05 at 05:18 PM
0

I had a similar problem after ios11.

Seemed to be related to the pdf viewer in the new message app
however it works in the acrobat pdf viewer that can be downloaded from the app store.

I found that if i deleted the fields that are showing the strange marks from the report and then re-create the fields again it seemed to fix the issue for me. Not sure if it was a slightly different field size or something.

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Hi Allan,

Thank you for the response!

We have tried to remove and add the fields with the hyperlinks but this doesn't solve the problem for us.
The strange thing is that when we use a pdf generated by Word the Hyperlinks are displayed correct.
Are you settings some properties on the field with the hyperlinks?

0

I am not using any hyperlinks in my fields.
They are either direct fields from the database or they are formulas
I am however using HTML Text Interpretation.

I tried everything to fix this, changing font, changing size, changing text/formulas etc
It wasnt until I completely removed the field/formula from the design and then added it back in that it worked.
I removed each affected field/formula and reapplied one by one checking that it corrected each area at a time.

Sorry I cant be more specific, I had 8 reports that it affected and I managed to fix every one in this way.

0
Don Williams
Mar 12 at 01:26 PM
0

Hi Guys,

So those black lines, are they the ones through the images in your report?

Can you take that image and export to pdf and see if that is the works? Do it from CR and then from some other app.

My IT department says that IOS 11.2.5 is not signed by Apple, meaning no longer supported.

Are there any settings you can adjust for viewing PDF's?

I'm thinking it may be related to the image interpritter for the PDF reader.

Any chance to get your report with saved data so I can test it?

Don

Share
10 |10000 characters needed characters left characters exceeded
Francine Coghe Mar 12 at 03:28 PM
0

Hi Don

No, those black lines are showing in the pdf after the export on ios.
This only seems to happen with hyperlinks.

We also created a pdf with a hyperlink from word and this doens't give stripes on ios devices.
As for the IOS version 11.2.5 that is no longer signed by Apple, updating to 11.2.6 version of IOS does not solve this issue.

As far as i'm aware, there are no specific settings i can adjust on the default pdf viewer of IOS.
A report together with the CR version that we are using has been send to you through mail.

Kind regards,

Jordi

Share
10 |10000 characters needed characters left characters exceeded