Skip to Content
0

Fiori Launchpad Does not consider SU01 default Language

Mar 01 at 08:49 PM

115

avatar image
Former Member

Hi,

Based on the help.sap.com article the FLP default language is supposed to be picked in the following order:

1. Language in URL

2. Default Language Maintained in SU01

3. Default Browser Language.

Setting Language Preferences for the Launchpad

I am trying to setup the system for the type 2 from the list above.

Reason: In production systems when SSO is used to log into FLP the users do not have an option to switch between languages or chose their default preferred language.

Issue: When I execute FLP the default from SU01 is not picked and it is always English (since the browser default is English). If I change the browser default to German; FLP will be loaded in German.

I have checked SICF the default language is not maintained for ushell:

SU01 Default:

The FLP URL:

https://<server>:<port>/sap/bc/ui5_ui5/ui2/ushell/shells/abap/FioriLaunchpad.html?sap-language=&sap-client=<client>

For me the priority that it is taking is:

URL parameter > Browser Language

Instead of what is mentioned in the help.sap.com -- URL parameter > SU01 > Browser Language.

Thanks and kind regards,

Sagar

untitled.png (73.2 kB)
untitled.jpg (61.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
John Taylor
Mar 01 at 11:09 PM
1

Where is it that the language you expect is not showing? There are different causes for this, such as SM59 destinations can cause data from the backend to come in a different language if the language is specified there, and I believe i18n files are selected based on the browser, not the values shown there.

If you change the sap-language parameter in the URL or user setttings, doe it show as expected?

Does the expected language show in the user settings of the launchpad?

Show 2 Share
10 |10000 characters needed characters left characters exceeded

*note, you should leave the language in SM59 destinations blank if you want the language to be dynamic/based on user instead of always being the same language.

0
Former Member

Hi John,

I guess i should have put a screenshot of the FLP homepage :)

The Issue is: When I log into FLP using SSO (which means i don't have access to the login page) - I see my FLP homepage (tiles etc) in English Language. Whereas in my SU01 I have set Germane DE as my default language.

URL: https://<server>:<port>/sap/bc/ui5_ui5/ui2/ushell/shells/abap/FioriLaunchpad.html?sap-client=370#Shell-home

For me the priority that it is taking is:

URL parameter > Browser Language

Instead of what is mentioned in the help.sap.com -- URL parameter > SU01 > Browser Language.

Kind regards,

Sagar

untitled.png (78.5 kB)
0