Skip to Content
author's profile photo Former Member
Former Member

SM59 - HTTP Connection to ABAP System fails

I am building an http conn from XI to ECC6 for ABAP proxy

On Connection Test, I get the error - ICM_HTTP_CONNECTION_FAILED

On running the trace in SMICM, I get the following:

-


[Thr 5] *** ERROR => Connection request from (-1/65535/0) to host: srpidev.srhouse.com, service: 8000 failed (NIEHOST_UNKNOWN)

[Thr 5] *** ERROR => IcmJ2EEScheduleFunc: Connection to srpidev.srhouse.com:8000 failed - please check host configuration (-8)

-


I get the foll on running the report: SPROX_CHECK_HTTP_COMMUNICATION

-


HTTP communication contains errors (see long text for diagnosis)

Message no. SPRX086

Diagnosis

The HTTP communication of this application server is not functioning correctly.

When calling the method

IF_HTTP_CLIENT=>RECEIVE

the exception

HTTP_COMMUNICATION_FAILURE

was triggered.

The short text for this exception reads as follows:

Communication Error

Procedure

Contact your system administrator

-


Can someone please help?

Thanks in advance.

Regards,

Prasad

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

3 Answers

  • Best Answer
    Posted on Jul 23, 2008 at 09:47 AM

    Hi,

    >>>>srpidev.srhouse.com, service: 8000 failed (NIEHOST_UNKNOWN)

    try putting IP instead

    does your ERP have access to XI on port 8000 ? (no firewalls issues)?

    Regards,

    michal

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hello All,

      We have finally solved the second part of the problem yesterday (R/3 to XI conn error).

      What happened is someone had previously configured http proxy in the R/3 system:

      SM59 > Extras > HTTP proxy configuration

      I guess this is required if there is a firewall/proxy between the R/3 and XI systems. But since in this case, there is no proxy in between, this config was not required.

      Once we deleted the proxy configuration (global settings/http log/https log) and the unchecked all the check boxes, the http conn worked.

      Thanks to all those who replied to this thread. I have awarded points to the helpful answers.

      Regards,

      Prasad

  • Posted on Jul 23, 2008 at 09:49 AM

    Check in sm59 that the RFC destination configuration is correct. For that check the the smicm -> Menu Goto Services -> Hostname and port.

    Also check that ur http service is running in sicf.

    Regards,

    Prateek

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 23, 2008 at 09:57 AM

    hi,

    not sure how -- but once when we got this error and nothing worked out, restart of the server did the trick...

    thanks,

    latika.

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.