Skip to Content
0

Your browser does not support SPNEGO. Authentication not possible

Mar 01 at 10:59 AM

153

avatar image
Former Member

SPNEGO configuration for sap HANA XS application:

we have followed the guide for Single Sign-On with SAP HANA® Database using Kerberos and Microsoft Active Directory.

However,browserprompt.jpgstudio-authentication-error.jpgtracefile.jpg we face the below error when checking the xsengine trace files.

e Authentication MethodSpnegoInternalAcceptor.cpp(00048) : initialize failed - SPNEGO not provided by the lib

We have activated the SPNEGO authentication from Hana Admin Console.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Michael Healy
Mar 01 at 07:36 PM
1

Hi,

What revision are you using? With SP12 onwards the kerberos libraries are delivered with the installation, so the environment uses this automatically, so this error should not be occurring. If you are below SP12 then this depends on the OS libraries...so you could just update to SP12, this would be the easiest open I guess.

If you are on SP12 already then to get an idea of what is happening here then you would need to run the traces specified in the Troubleshooting SSO Kerberos Note

Without these traces it will be impossible to know

Show 11 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Michael,

Thanks for your response, We were on SP09 when facing this issue and hence upgraded our system to RHEL 6.5 and SPS12. We are still facing the same error post upgrade. Is there any post upgradation steps to be performed for the inbuilt kerberos libraries to reflect?

0

No, nothing like that. Did you run the trace? I see you have a ticket open for this also. We need traces to see what the issue is

0
Former Member

Traces have been uploaded.

0

Ive looked at the traces and as communicated in the incident, these are very old traces. There are OOMs and crashes in the statistics server. This could not be possible on your current SP12 version as the stats server is embedded in the indexserver....so go back and gather the correct traces. Don't use HANA Studio to gather the traces, use the OS method.

There are two different issues here:

1: Your indexserver is crashing

2: Your SSO isn't working.

I would suggest you gather the correct traces to deal with the first issue. Once this has been identified then you can deal with the authentication issue.

0
Former Member

Hi Michael,

I've gathered the traces at OS level. You may find it on the server.

0

Once they are uploaded to the mobile documents link I can have a look

0
Former Member

Archives have already been uploaded on the mobile documents link. Hope you can view them.

0
Former Member

Hi Michael,

I have been able to successfully run SSO for my application. Although I'm unable to take a database backup through HANA studio as I receive the following error:

backup could not be completed, [70012003] connection broken, [110046] Communication failure with service 'statisticsserver' at 'domain' responsible for the volume '3'

Seems like Statistics server or the index server is getting crashed. We are also facing memory issues on ur drive. Does that have something to do with this error. backupconfigurationerror.jpgbackupcatalog-error.jpg

Please find attachments.

0

You're going to have to Embed your statistic server, it should not be standalone. You're using SP12, it should already be embedded in your indexserver. Please migrate the stat server to an embedded version.

0
Former Member

Hi Michael,

Please guide me on how to migrate the statistics server.

Which of these notes are feasible for my case-

1950221 - SAP HANA DB: Reinitializing the Statisticsserver

2092033 - Embedded Statistics Service Migration Guide

0

Note 2092033 - Embedded Statistics Service Migration Guide would be the guide to follow

1
Imtiaz Karedia Mar 01 at 04:52 PM
0

Are you using firefox? If yes please set the below two parameters.

network.negotiate-auth.delegation-uris like http(s)://<hostname>:<port>

network.negotiate-auth.trusted-uris like http(s)://<hostname>:<port>

Show 1 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Imtiaz,

Thanks for your response, I've already done this configuration on FireFox but the error remains same.

0