Skip to Content
avatar image
Former Member

Error after the smartform was imported to production

hi Guys,

We transported the smart form to production and we tried to execute the program and it dumped with the messaage CALL_FUNCTION_NOT_ACTIVE. This is working fine in Dev and Quality systems. For some reason it is giving this weird error in production.

Can some one help me fix this issue. May be you might have already come across this issue earlier.

I am assuming that the smartform did not get generated after the transport was imported to prodction.

We are on version 46C

Regards,

Jitendar

Edited by: Jiten Reddy on Jul 23, 2008 4:31 AM

Edited by: Jiten Reddy on Jul 23, 2008 4:32 AM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • avatar image
    Former Member
    Jul 23, 2008 at 04:29 AM

    hi,

    first of all check all the functions modules which you used in the driver program and smartform are active ( first activate) and then again transport to production then it works fine , like if u call a FM read_text , u have to maintain the exceptions and should maintain the status to be active then only it works. check the status of FM in production also.

    regards,

    venkat./>>>>>>>>>>>

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 23, 2008 at 06:03 AM

    hii

    May be some modifications are not reflected in production.

    or May be After modification,the request does not relesed.

    then Transport smartform,once again in active state and check in production.

    Check it up once again...

    reward points if helpful

    Thanks

    satya

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 23, 2008 at 08:37 AM

    hey,

    some times it does happen that the function module does not get generated in production client and hence when the system checks for the function module it is not found and ultimately goes to dump, you just need to open the smartform in display mode in production client and then just run it manually ( not through the transaction) , what happens is the function module would be generated. Please note that this is required only once.

    After that check with the tracsaction.

    I think this should solve your problem .

    reward if uselful.

    regards,

    Krishna prasad.K

    Edited by: krishna prasad on Jul 23, 2008 1:03 PM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 23, 2008 at 08:46 AM

    Hi,

    Try to generate the smartform through the transaction SMARTFORMS from the menu smartform--> generate...

    If still the problem persists then re-transport the smartform to production and check again.

    Regards,

    Ram

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Jul 23, 2008 at 06:50 PM

    We got the authorzation to smartforms transaction in production and generated for the form and it started working.

    Thanks for all your replies.

    Add comment
    10|10000 characters needed characters exceeded