Skip to Content
author's profile photo Former Member
Former Member

Creating SO for Matnr in PlantA, Message says Matnr doesn't exist in PlantB

Hello,

I am trying to create a Sales Order for a Material which triggers a creation of Auto Purchase Requistion eventually to Purchase Order.

The Material exists in Plant A and my delivering plant for the material is also Plant A.

When i create the Sales Order for the material i get a message saying Material doesn't exist in Plant B.

I am not sure why Plant B comes into picture, Note: Plant B is one of our another plants.

Can someone provide any inputs.

Best Regards,

Bharat.

Add a comment
10|10000 characters needed characters exceeded

Related questions

3 Answers

  • author's profile photo Former Member
    Former Member
    Posted on Jul 20, 2008 at 10:02 PM

    Hi

    You are right that why plant B comes into picture. I dont see any other reason please check material master again and plant that is SO line item. Somewhere it must be Plant B

    Thanks

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 21, 2008 at 03:52 AM

    Hi Bharat,

    Please check storage loction assigned to your materail and special procrument key.

    Regards,

    R.Brahmankar

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Jul 21, 2008 at 04:02 AM

    Bharat,

    Check MRP2-View of the material master in Plant A, there must be a specical procurment key assigned which may be prompting to plant B. Please make this field Blank, incase there is no Special procurement happening.

    Regards,

    Prasobh

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Guys,

      We have resolved the Issue. Just wanted to update the group what the issue was and how resolved,

      We checked the Auto PO flag in the ItemCategory settings and we are using that particualar ItemCategory linked to the Item Category Group in the Material for which we are creating Sales Order.

      It seems if the Auto PO flag is checked and since that flag is treated as an EDI enabled one, when a Purch. Req / PO is created is gets the Plant value from the Sales Org settings in the Enterprise Structure (SPRO). In our systems that happened to be Plant B.

      Hence when am trying to create a SO (Plant A) and eventually to a Purch. Req / PO it is saying the Material is not present in Plant B.

      It took a while for me to digest, but that is what it is.

      Best Regards,

      Bharat.

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.