Skip to Content
avatar image
Former Member

Hybris Marketing Campaign Follow Up Triggers

Hi Guys,

I have issues with marketing campaigns with follow up triggers (User Interaction). This feature is available from 1709 (on premise).

I use User Interaction (Website Registration) as follow up trigger. Once I create the Interaction (Website Registration), I can see the IA created but my campaign does not go further to send a next action e.g. Email.

I have also debugged Listner Report (CUAN_MKT_EXEC_LISTENER), there is a BatchJob for this report that runs every one minute. The listner report does not get IA (Website Registration) to create an event in the system. Even I have seen HANA Views that delivers the IAs for the trigger. These HANA views do not deliver the IA to the report.

HANA Views:

CA_C_MKT_ORC_RT_TRIGGER_BASED CA_D_MKT_ORC_RT_FOLLOW_UP_TRIGGER

But all in all, as an end user, once the IA (Website Registration) has been posted i assume system should raise a trigger so that my campaign can send me next email action.

follow-up-trigger-hana-view-2.png

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

3 Answers

  • Mar 01 at 08:56 AM

    Hi Naeem,

    have you activated the campaign trigger in IMG? If yes and it still does not work I guess you have to open a support ticket.

    Regards,

    Matthias

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Matthias,

      Ofcourse I have already activated the campaign triggers.

      campaign-triggers.png

      I am debugging the Import oData service.

      I follow the instructions mentioned at (yMKT Help), I supply the OUTBOUND-ID with my IA Type. The oData returns me 201 (OK status) but even than I don't see any new IA created. During debugging, i found out, it enriches my IA record using OUTBOUND-ID to get the earlier executed action (Email sent out). So it uses the Comm. Medium form that earlier IA together with "Website Registration", of course, "Website Registration" is not customized with comm. Medium "Email". It leads me either to create that combination in customizing (Assign Interaction Types and Communication Media to Channels). I have tried, and it works, it creates the IA now. BUT even then my campaign follow up trigger has not raised.

      Is there any example, how to raise the campaign follow up trigger (user Interaction), that would be more related to my issue.

      Best Regards,

      Naeem

  • Mar 01 at 04:14 PM

    Hi Naeem,

    Did you find any solution??

    We are having a similar issue where the Trigger based campaigns are not triggering at all.

    I am trying to use the standard Shopping Cart abandoned scenario and using the FM CUAN_CE_INTERACTIONS_POST_FLAT to create an interaction but it does not execute the campaign. I do not see any job triggered in SM37 for Campaign Execution.

    Also, since we do not have emails enabled yet so i am using the Export action in the trigger based. Is there any limitation on what actions are supported by Trigger based, the pre-delivered campaign category "A3" also supports Export so not sure what is missing. The regular campaigns are working just fine and listener job is running as well but for some reasons the campaigns are not triggered. We tried uploading data with ODATA calls as well and still no change.

    Thanks

    Vineet

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Vineet,

      I still have above issue. I am debugging the IMPORT oData service. I am able to create the IA but my campaign trigger does not raise an event so that my YES part of the campaign follow up trigger can go on. I assume NO part (non-event) trigger should work out of the box after given deadline (days) are over. I would try to check trigger based campaign on my side and come back to you tomorrow. We have issues today after updating 1709 SP01 (on premise), once fixed, i would be able to create and execute campaigns again.

      Naeem Khan

  • Nov 25 at 11:15 PM

    Hi,

    Did you find any solution for this??

    Regards, Ajit

    Add comment
    10|10000 characters needed characters exceeded