Skip to Content
0

Values not Assigned Correctly in BPM Process on PRO 7.50

Feb 28 at 09:31 AM

70

avatar image
Former Member

Hi all,

I developed a BPM process on PRO7.50 which executes an Operation Mapping within a automated activity. The target structure of the mapping is provided in an external definition in ESR. I modified the wsdl to have xmlns and targetNamespace attributes on the wsdl and xsd:schema nodes. Also I changed the root element data type to a named complex type. It should be compliant for the usage in the process now.

Import worked without errors. The data object "TargetData" uses the datatype of the receiver interface.

I created the input and output mappings for the actitvity:


The Problem:

The target structure of the mapping ("TargetData") is always empty. All field are created but there are no values in it:

I testes the mapping two ways:

  • In the test tab of ESR
  • I addd an automated acitivity in the BPM process which sends the source structure to AEX, then a "normal" interface is triggered which executes the mapping

In both cases, the mapping result is as expected. This leads me to the assumption that the way the way the process interprets the wsdl for the target structure is different. The values seem to be provided by the mapping but in the output mapping of the automated activity they can not be assigned to the fields of the data object.

I already tried different combinations of namespaces, created a new interface, created a new mapping, nothing worked.

Can anyone give me a hint?

Thanks!
Stefan

1.png (20.3 kB)
2.png (26.8 kB)
3.png (28.6 kB)
4.png (34.9 kB)
5.png (29.0 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Gabriel Cassel
Feb 28 at 06:04 PM
0

Hi Stefan,

Check this blog about the Mapping and let me know your findings. https://blogs.sap.com/2012/06/11/using-netweaver-pi-s-mapping-in-netweaver-bpm/ Also you can try to deploy the BPM support tool which is contained in it. 1695099 - SAP NetWeaver BPM Support Toolkit After this open the BPM support tool and export the two problematic processes from the Export Process section. After this, you can export the results.

Kind regards,

Gabriel Cassel

SAP Product Support

Share
10 |10000 characters needed characters left characters exceeded