Skip to Content
0

Replicate Business Partner/Relationship from C4C to S/4 HANA, SRT: HTTP Code 404: Not Found

Feb 26 at 10:59 PM

388

avatar image

Hi SAP Community!

Recently we faced an issue around 'Sales Orders Replication from S/4 Hana to C4C', it was solved with this note: https://launchpad.support.sap.com/#/notes/2584570

Basically this was the error:

Outbound replication web-service messages fail in Cloud for Customer with detailed Error Context logs pointing to incorrect Operation_Name as "CreateSequence".

*We had the same error in the 'Business Partner / Relationship Replication from C4C to S/4 HANA'

createseq1.jpg

createseq2.jpg

Fortunately was solved with the previous note too :)

-------------------------

Right now we are troubleshooting the 'Business Partner / Relationship Replication from C4C to S/4 HANA' scenario, we have an error i think about the Business Partner Relationship Replication.

error1.jpg

Everything seems to be fine about the Business Partner Replication, but not with the Relationship. The 'BusinessPartnerRelationshipReplicationSelfInitiatedOut' interface is getting this error:

'SRT: HTTP error: ("HTTP Code 404: Not Found - Details see in error log of transaction SRTUTIL")'

error11.jpg

Here you can see the details about the error:

error2.jpg

error3.jpg

It seems that maybe we have some inactive services in the SICF trx in S/4 Hana, but the error doesn't provide much information about the service path.

The iflow in HCI looks ok

hci-ok.jpg

Here the entries in the SRTUTIL trx in S/4 Hana

srtutil1.jpg

srtutil11.jpg

Again, it seems that we have some inactive services, but there is not details about the paths.

Could you provide any suggestions?

Thanks in advance!


createseq1.jpg (356.8 kB)
createseq2.jpg (208.1 kB)
error1.jpg (372.7 kB)
error11.jpg (303.6 kB)
error2.jpg (200.8 kB)
error3.jpg (208.8 kB)
hci-ok.jpg (132.4 kB)
srtutil1.jpg (463.1 kB)
srtutil11.jpg (472.6 kB)
10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

2 Answers

Best Answer
Sikander Narula
Feb 27 at 05:25 PM
0

Dear Juan Carlos Camacho Garduño,

Please check the service URL maintained in the C4C communication Arrangement is correct and matching the HCI IFlow endpoint url

Thanks and Regards

Sikander

Show 2 Share
10 |10000 characters needed characters left characters exceeded

Thanks Sikander!

We did a double check around the URLs in HCI iFlow and C4C Communication Arrangements, looks ok.

'Replicate Business Partner Relationship to SAP Business Suite' iflow endpoint

iflowpath.jpg

C4C CA for Business Partner Relationship

c4cpath.jpg

Thanks!

iflowpath.jpg (186.9 kB)
c4cpath.jpg (241.4 kB)
0

Hello!

The issue was about "Replicate Business Partner Account Team to SAP Business Suite" Service from the "Business Partner Replication to SAP Business Suite" Communication Arrangement.

The service was active, but the path field was missing in the service.

wrong.jpg

path empty

maintain.jpg

Ok

After this change, everything works fine!

wrong.jpg (128.5 kB)
maintain.jpg (102.5 kB)
0
Manideep Satya
Feb 27 at 02:24 AM
0

Dear Juan Carlos Camacho Garduño,

The outgoing messages from C4C with service interface "BusinessPartnerRelationshipReplicationSelfInitiatedOut" fails with error "HTTP Code 404 not found" which means the relevant iflow is not active in HCI. For this message there is no point in checking S4H logs as the call is not processed successfully in HCI.

The iflow you have attached is relevant for Business Partner Replication from C4C to SAP Business Suite but not Relationship replication. Please check the relevant iflow in HCI if it is configured or not? If it is configured, please check in monitor if it is active or not.

Regards,
Manideep Satya

Show 5 Share
10 |10000 characters needed characters left characters exceeded

Hello Satya, Thanks for feedback!

The iflow 'Replicate Business Partner Relationship to SAP Business Suite' is already configured / deployed in HCI, I even deployed again. This iflow is simply not triggered / executed in the Monitor.

bpriflow.jpg

and the config

iflowconfig.jpg

We are getting the same error in C4C Monitoring, but still troubleshooting...

'SRT: HTTP error: ("HTTP Code 404: Not Found - Details see in error log of transaction SRTUTIL")'

Regards!

bpriflow.jpg (116.8 kB)
iflowconfig.jpg (204.7 kB)
0
Former Member
Juan Carlos Camacho Garduño

Dear Juan Carlos Camacho Garduño,

I am trying ti establish the business partner - contact relationship using Business partner replicate from sap business suite , getting an error in webservice monitoring as The reference business partner is not known to the system , I have checked the ID MAPPING against the bussiness partner it's already there .. could you provide some inshight as you have already tried this .

0

Hello Swagatika Rout!

I can provide some feedback if you post the details about your error here in the community and share the url.

Regards!

0
Former Member
Juan Carlos Camacho Garduño

Dear Juan Carlos Camacho Garduño,

Thanks for your response .

Here is the link to the error.

https://answers.sap.com/questions/481680/error-when-trying-to-replicate-contact-relationshi.html

Regards,

Swagatika

0

Dear Juan Carlos Camacho Garduño,

Last try , if you have installed eclipse , activate the tail log for tenant management node and do the test or reprocess the failed message from C4C - then you may get some information. Otherwise we suggest you to create an incident for this problem.

Regards,
Manideep Satya

0