Skip to Content
0

Report Engine Crashes When using Print icon, or export button

Feb 26 at 10:58 PM

17

avatar image
Former Member

I rewrote an RPT , cutting and pasting from the previous report. After getting it working, I tried to print. Using VS 2013, VB.NET and CR 13.0 32-bit. My other reports print and export just fine. Only this new report. The new RPT is 'launched' from the same vb code that I used previously, just changing the MyReport name. When I press the Printer Icon, the report display goes blank (only my "Close" button remains). The entire CrystalReportsViewer1 is blanked. However, the select Printer windows and printing does work. Now, running outside the debugger, the screen goes blank, and pressing Print from the Print window...CR Crashes - See Below.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at System.Windows.Forms.ToolStripControlHost.set_Enabled(Boolean value)
at CrystalDecisions.Windows.Forms.PageView.updateForEmptyPage()
at CrystalDecisions.Windows.Forms.PageView.RemoveExistingReport()
at CrystalDecisions.Windows.Forms.CrystalReportViewer.set_ReportSource(Object value)
at I_Track.TourManifestLauncher.TourManifestLauncher_Deactivate(Object sender, EventArgs e) in C:\Development\Sound-Tracker\I-Track\TourManifestLauncher.vb:line 598
at System.Windows.Forms.Form.OnDeactivate(EventArgs e)
at System.Windows.Forms.Form.set_Active(Boolean value)
at System.Windows.Forms.Form.WmActivate(Message& m)
at System.Windows.Forms.Form.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)

Not sure what to try??

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Don Williams
Feb 26 at 11:00 PM
0

Are you using the latest CR runtime from here:

https://wiki.scn.sap.com/wiki/display/BOBJ/Crystal+Reports%2C+Developer+for+Visual+Studio+Downloads

Try right clicking on the EXE and selecting Run As Administrator.

Share
10 |10000 characters needed characters left characters exceeded