Skip to Content
0

Unable to find URL for Adapter Engine com.sap.aii.connect.directory.name

Feb 26 at 05:29 PM

98

avatar image
Former Member

Hi

We facing are INTERNAL">AE_DETAILS_GET_ERROR Unable to find URL for Adapter Engine com.sap.aii.connect.directory.name</SAP:AdditionalText> <SAP:Stack>Error while reading access data (URL, user, password) for the Adapter Engine in All of our working scenerios all of sudden.

here is the trace :Sxmb_moni.

<Trace type="T" level="2">Integration Server is.01.qaspi found </Trace> <Trace type="T" level="2">Integration Directory directory.qij.qaspi found </Trace> <Trace type="T" level="2">AdapterFramework name: af.qij.qaspi </Trace> <Trace type="T" level="1">error reading from exchange profile:handler for LCRBEAN_GET_PROFILE_PARAMETER was not </Trace> <Trace type="System_Error" level="3">Error while reading access data (URL, user, password) for the Adapter Engine </Trace> </Trace> </Trace> -<Trace type="B" level="1" name="CL_XMS_MESSAGE_PERS_MAN-WRITE_MESSAGE_TO_PERSIST"> <Trace type="T" level="3">Persisting message Status = 023</Trace> <Trace type="T" level="3">Message version 009</Trace> <Trace type="T" level="3">Pipeline CENTRAL</Trace> </Trace> </Trace> <Trace type="T" level="1">An Exception has occured </Trace> <Trace type="T" level="1">Error Text: Error while reading access data (URL, user, password) for the Adapter Engine </Trace>''

Urgent help Required.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

José Antonio Roldán Luna Feb 26 at 05:59 PM
0

Please,

Check Michael Krawczyk answer of this post. https://archive.sap.com/discussions/thread/19311

Try to check the same parameters on Exchange Profile.

BTW.

Please never provide system names :P

Regards,

Jose.

Show 2 Share
10 |10000 characters needed characters left characters exceeded
Former Member

Hi Jose.

Thanks for the input. yeah my bad:p I already check Michael Krawczyk answer but my scenerio was all working fine, it means configeration was ok, but all of a sudden it went into this error. ps i am using PI 7.5

0

Once time when I was uploading axis framework bean. The com.sap.aii.adapter.lib.sda module was broken and I have similar error in sxi_monitor.

If you cannot fix this error, in the last case, try to reimport Adapter Engine Component.

I have seen a guide for doing that but it is for 7.4. But can also apply.

https://blogs.sap.com/2015/02/23/process-integration-74-aex-advanced-adapter-engine-extended-on-standalone-sap-java-installation-and-configuration/

Regards,

José.

0