Skip to Content
0

PowerDesigner Web 16.6SP2 HTTP 404 Error on UNIX

Feb 26 at 11:25 AM

32

avatar image
Former Member

Hello,

i followed the tutorial about installing PowerDesigner Web on UNIX Systems. After starting the Tomcat i get a HTTP 404 Error /powerdesigner-web/resources/index.html not found.

I did exactly what the official tutorial told me to do. I tried the same thing with PowerDesigner Web 16.5SP4 and it worked fine without problems (same Tomcat configuration).

I installed PowerDesigner Web on a virtual machine first and copied the files on my UNIX system.

So what am i doing wrong?

Edit:

Philipp Lam helped me with telling me that PD Web is using nodejs with version 16.6. I installed nodejs on my UNIX machine and started the nodeserver (located in the PD files under "nodeserver") and copied the config files from the Tomcat directory of the PD files in the conf directory of my tomcat machine. After the nodeserver started i have started my Tomcat and it worked.

I would´ve save much time if SAP refreshed its documentation.

Problem is solved now

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Best Answer
Phillip Lam
Feb 27 at 05:07 PM
0

There are two services are running.

PowerDesigner 16 NodeServer

PowerDesigner 16 Portal

The problematic file index.html is located at Powerdesigner Portal/nodeserver/resources.

Make sure nodeserver is running and it can find the missing file.

Share
10 |10000 characters needed characters left characters exceeded