Skip to Content
avatar image
Former Member

SXI_MONITOR: Scheduled for Outbound Processing

Hi folks,

After a connection problem with AE, now already fixed. Iu2019m experiencing a strange issue!! It occurs at only one interface where the message gets stuck at SXI_MONITOR with the status u201Cscheduled for outbound processingu201D without any entry at SMQ1/2 or SM58 u2013 this interface is an ABAP proxy to IDoc. Only at RWB I can see those entries with status u201Cwaitingu201D at Integration Engine. However, every time I try to resend or cancel I get the following error: u201CUnable to cancel/resend 1 of 1 messages; update the statusu201D.

After I read several threads with similar issue I expend all the tips suggested, unfortunately without success.

What I did:

SLD, Adapter Meta data, CPAcache, sxi_cache cleared,

AE entry at sxi_cache deleted,

RWB - Cache test ok,

Deregister/Register and activate all queues,

IDoc adapter deleted,

All ID objects related to this interface were deleted and created again,

Several j2ee restarts,

stop/start sap,

IDX2 u2013 IDoc meta data deleted,

Changed manually the message status directly at table SXMSPMAST to a restartable status.

All PI components are in green status.

Curiously at sxi_monitor I changed the layout in order to check which queue id my message is getting stuck and I found u201CPACKAGEu201D as queue name. I donu2019t know which kind of queue is this u201CPACKAGEu201D!

Anyone knows what is going on here?

Thanks in advance,

Ricardo.

Edited by: Ricardo Quintino on Jul 15, 2008 9:57 PM

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 15, 2008 at 09:16 PM

    Ricardo,

    Are there any other messages for the same interface in "System Error" status?

    Try running the SXI_MONITOR for the interface and status "System Error" and dates as wide open.

    If you do find a message with "System Error", cancel it and try resending or cancelling your waiting message.

    Regards

    Haseeb

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Haseeb,

      Thanks for the tip, but I don't have any message in "System Error" status. Only successfully processed or in Waiting status at IE (sxi_monitor: scheduled for outbound porcessing).

      Any ideas?

      Regards,

      Ricardo.

  • avatar image
    Former Member
    Jul 16, 2008 at 08:28 AM

    Hi Ricardo,

    Check if transaction SLDCHECK gives a green status. If not, check the configuration in SLDAPICUST transaction. Make sure that the user maintained here is not locked.

    Also, ensure that the user maintained in the RFC destination used in IDoc adapter is not locked. Run a connection test.

    If you have selected Queue processing, the name of the queue is possibly picked up from source adapter or source system.

    Regards,

    Riyaz

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member Former Member

      Hi Ricardo,

      After sometime are you able to see your message working as required or it will be in wait status.

      Thanks

      Sudharshan

  • avatar image
    Former Member
    Jul 16, 2008 at 03:09 AM

    Hi

    Check inbound and outbound queues in transaction SMQ1 and SMQ2.

    If you find anything stuch there with "system error" then delete that entry and Re-register your queue in transaction SMQR.

    And again run your scenario.

    Rregards

    Sami

    Reward points if helpful.

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 16, 2008 at 08:04 AM

    Hi,

    Scheduled status may come for different reasons,

    1) Receivers are not ready

    2) Queues are stuck up

    3) Connection Problem

    4) Waiting for the confirmation etc..

    But it is prefer to check the status in the transaction SMQ2 in the XI box. I know you already did it. There are some better ways like to try re registering the queue.

    Also this blog may help u-

    XI : How to Re-Process failed XI Messages Automatically

    if nothing is helping, then restart the server may help. lets c.

    Regards

    Aashish Sinha

    PS : reward points if helpful

    Add comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Aashish,

      I already read this blog and as I said on my post I also did a stop/start sap (restart server).

      But thanks anyway,

      Ricardo.

  • avatar image
    Former Member
    Jul 17, 2008 at 01:53 PM

    Hi All,

    After I understood the meaning of u201CPACKAGEu201D as queue name at RWB > Message Monitoring, Integration Engine column and therefore Iu2019ve checked the pipeline steps. I realized some information was missing in the ABAP part in order that the pipeline can continue the execution; somehow PI lost the link at step Request Message Mapping.

    Consequently, I recreated the interface for a new one in order to sidetrack any relation between the old and this new, in addition instead of a business system I used a business service with XNU logical system name for IDoc use and it gladly it works.

    Now I have a different interface (different objects) but with the same kind of scenario and the same endpoint.

    Thank you all, cheers,

    Ricardo.

    Add comment
    10|10000 characters needed characters exceeded