Skip to Content
avatar image
Former Member

Unable to deploy from NWDS to Portal server

Hello Friends,

We have Portal up and running. We could deploy a .EAR files from backend SDM - remote GUI.

We have configured portals server properly in NWDS windows--preferences. We could see server running in SAP J2EE engine view in NWDS. However we are unable to deploy any application to portal directly from NWDS. It is giving following error

Cannot connect to Host: [*********] with user name: [Administrator] Check your login information. Exception is: com.sap.engine.services.jndi.persistent.exceptions.NamingException: Exception during getInitialContext operation. No server is running.

[ Root exception is .sap.engine.services.security.exceptions.BaseLoginException: Exception in creating new RemoteLoginContext instance.]

Are we missing some connection ?

Thanks

Shobhan

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

6 Answers

  • Best Answer
    avatar image
    Former Member
    Jul 15, 2008 at 02:23 PM

    Hi,

    Check if administrator userid & password is stored correctly in secure store in configtool.

    Regards,

    Apurva

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 16, 2008 at 05:32 AM

    hi,

    he J2EE Engine is not started or there are problems with the normal J2EE starting mode. Check if the J2EE Engine is started and if it is not, start the engine and try again to get an initial context. If the engine is up and running, see below.

    http://help.sap.com/saphelp_nw70/helpdata/en/f4/302c4142aef623e10000000a155106/content.htm

    also SDM unveiled

    check [SDM troubleshooting|http://help.sap.com/saphelp_nw70/helpdata/EN/76/fb72ec091f4bf8a2d8ba321bb7e8d9/frameset.htm]

    regards,

    Pradeep

    Edited by: pradeep bondla on Jul 16, 2008 7:35 AM

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2008 at 12:19 PM

    Hi Shobhan

    Check your nwds setting once. During deployment its getting some junk host name thats why u r getting message server is not running.

    Regards,

    sukanta

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2008 at 03:17 PM

    Hi,

    Check NWDI Settings :

    1. Wndow>>Preferences >>SAP J2EE Engine>> make sure that Message server host and port.

    May be you have to check on Security session expiry time on server nodes. Some times the values were not the same on all the server nodes. Make sure this value is same on all server nodes.

    Thanks

    Krishna

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 17, 2008 at 03:25 PM

    Shobhan,

    Check SAP Note 701654. This may be helpful.

    Vishwas.

    Add comment
    10|10000 characters needed characters exceeded

  • avatar image
    Former Member
    Sep 18, 2008 at 05:29 AM

    Hi Shobhan,

    Check for ur administrator password..of portal on which u r deploying ur application

    it must b changed or locked..

    Regards

    Khushboo

    Add comment
    10|10000 characters needed characters exceeded