Skip to Content

SAP PI 7.5 Mapping Resource not Found Unable to find resource *in the following software component

Feb 24 at 04:18 PM


avatar image


Recently we upgrade our pi system from pi 7.0 to pi 7.5 single stack (Dual usage, Dual split) after upgrade pi scenario were working fine, and handed over to customer, after few days we are facing some strange and uncertain behavior in pi scenario, now all of our scenario falling into error "Unable to find resource 70f31500-88af-11e3-b09f-c5f60afe1082 in the following software component versions: http://""".*.*.service.comcom/sap/xi/tf/*********_.class-1 </SAP:Stack> strange thing is that when tried the same scenario it started working fine, then tried it again fall into error, all of the scenario is showing this kind of uncertain response.

for resolution i tried delta and full cache referesh, but nothing works for me, i reconfigured my SLD configuration but nothing can help, every same uncertain behavior seen.

here is my trace for sxmb_moni when scenario fall into error state.

......attachment XI_Context not found Mapping already defined in interface determination Object ID of Interface Mapping E6C9E89D607F3AC9BABD05DEA29D02C3 Version ID of Interface Mapping 70F3150088AF11E3B09FC5F60AFE1082 Interface Mapping http://*.*.*. *_*_* Mapping Steps 1 JAVA com/sap/xi/tf/_*_*_*_ MTOM Attachments are Transferred to the Payload Dynamic Configuration Is Empty Mode 0 Search com/sap/xi/tf/_*_*_*_.class (http://*.*.*, -1) in swcv 70f31500-88af-11e3-b09f-c5f60afe1082. Search com/sap/xi/tf/_****_.class (-1) in swcv 70f31500-88af-11e3-b09f-c5f60afe1082 without namespace. Unable to find resource com/sap/xi/tf/_*****_.class in the following software component versions: 70f31500-88af-11e3-b09f-c5f60afe1082 Thrown: Unable to fin d resource com/sap/xi/tf/_***_.class in the following software component versions: 70f31500-88af-11e3-b09f-c5f60afe1082 at at at

Please help me guys, as already Searched Scn.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

1 Answer

Anoop Rai Feb 24 at 08:38 PM


Its a general problem with PI/PO, specially when we move fresh objects from one landscape to other specially by file, due to version ids in ESR & ID objects.

Just delete and add operational mapping under receiver interfaces of ICo.



Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hi Anoop,

Thanks for valuable input, but we are not using ICO scenerio's we are using dual stack split(dual usage) which are conventional scenario's like Receiver determination and interface determination, and we are facing this responce in our all scenerio's.