Skip to Content
0

SAP Identity Management 8.0, SP03, issue updating IdStore schema

Oct 26, 2016 at 11:19 PM

96

avatar image
Former Member

Hello,

I recently got an answer to a question about displaying the system configuration tab in the admin console. The solution required applying SP02 or SP03. I chose to apply SP03 and did the research to identify all the requirements outlined in the installation guide

The problem I ran into was with the first action, running the 'mxmc-update' command. The script successfully completes for updating the MXMC_db schema, but when it gets to updating the 'IdStore schema' it throws an error related to the JDBC connection and specifically the CLASSPATH parameters. Also, when I checked the 'mxmc-update-log' file there are two noted syntax errors and one stored procedure that can't be found

(mxp_init_ids_lang).

Here is a screenshot of the JDBC error message. What caught my eye was the '.\*' that preceded the path string that I'm asked to enter after running the command.

Here are the errors that were in the mxmc-upate-log.

Msg 105, Level 15, State 1, Server ,<HOST NAME>, Procedure mxp_init_ids_lang, Line 832 Unclosed quotation mark after the character string '? (long string after this)

Msg 102, Level 15, State 1, Server <HOST NAME>, Procedure mxp_init_ids_lang, Line 832 Incorrect syntax near '?(long string after this)

Msg 2812, Level 16, State 62, Server <HOST NAME>, Line 2

Could not find stored procedure 'mxp_init_ids_lang'.

What I'm wondering at this point is how to resolve the JDBC connection error. I'd also like to know if there's a work around for this and how important updating the IdStore schema is?

As always appreciate the help.

Paul

No one having this issue? haven't received any responses, just thought I'd check.

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

0 Answers