Skip to Content
avatar image
Former Member

getting error in cloning repository from github in SAP Web IDE Full-Stack

Hi,

I want to clone my repository which is present on https://github.wdf.sap.corp/. But I am getting the following error.

Clone request failed

SAP Web IDE is not configured to trust the security certificate provided by the Git server.

I am using SAP Web IDE Full-Stack on https://account.int.sap.hana.ondemand.com.

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

5 Answers

  • Feb 25, 2018 at 07:19 AM

    Tomer Epstein Michal Tall - Can you please assist?

    Thanks,
    Michal.

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 03, 2018 at 10:17 AM

    Hey Tomer, I seem to have the same problem, can use please specify what you have done to solve this?


    1. Where exactly did you put the port number?

    2. You added a new entry to the Git Repository Configuration in the WebIDE project {key: remote.origin.hcpdestination, value: [youtgitrepository]}?


    Thank you,

    Thomas

    Add comment
    10|10000 characters needed characters exceeded

  • Sep 05, 2018 at 01:48 PM

    same same.

    Need the answers as well :)

    Best,

    Felix

    Add comment
    10|10000 characters needed characters exceeded

  • Jul 31, 2018 at 07:19 AM

    Issue resolved.

    1. We add the port number 443 to the destination url in SCP Cockpit.

    2. We add missing remote.'origin.hcpdestination' entry to existing git project

    3. There is no need to upload certificate when working with github.wdf

    Add comment
    10|10000 characters needed characters exceeded

  • Oct 31, 2018 at 03:09 PM

    I had the same issue and more. I went round in circles trying all the advice then eventually solved it. Sharing my approach as it might help someone.

    For reference, I'm running on the new Web IDE Full-Stack and using a third-party Git provider.

    I found the Git server treated my email address as case sensitive. E.g. Paul@... wouldn't work from Web IDE but lowercase paul@... worked eventually.

    I'm using a different email address to my web IDE one so I had to put it in the Global Preferences - Git Settings. This is the gear icon at the bottom of the left toolbar. I had to put it in lowercase here. It was originally defaulted to my Web IDE email address. You should also check the Project Settings Git Repository Configuration as that also has user.email and user.name which I think it copies from the Global Preferences.

    I think the process worked better when I clicked "Remember me" on the Authentication password popup. I had left that box blank on some of my failed attempts, but maybe it needs to be ticked.

    I also got a different result once when I simply closed the browser and reopened Web IDE and tried the same action.

    Hope this helps someone. Good luck!

    Add comment
    10|10000 characters needed characters exceeded