Skip to Content
0

Problem adding custom field to segmentation

Feb 23 at 09:00 AM

103

avatar image
Former Member

Hi,

I want to add a new field for interaction contact in Hybris Marketing to use this field in a landing page web form to be filled. I also want to add the new field to segmentation. Adding the field and including it in a web form (landing page) is no problem, but I have a problem adding the field to my segmentation.

First, I created the field using the app "Custom fields and logic". The field is "Web Form Interest" (list type):

Then I go to app "Add custom fields in segmentation". Create a new entry, add business context and segmentation object. In the list, the good news is that the new field I created appears. I select the field (mark checkbox) and click "Set visible".

After that I click save. The entry is saved and displayed in the list on the left navigation panel. The strange is that when I select the newly created item again and I have a look in the custom fields, my field has disappeared. My field "Web Form Interest" does not appear in the saved assignment:

Even when I click and edit the item again, the field is not visible in the selection.

What is wrong? Can anyone help me? All other fields are working, but not my new created custom field.

Br

Christian

10 |10000 characters needed characters left characters exceeded
* Please Login or Register to Answer, Follow or Comment.

4 Answers

avatar image
Former Member Feb 23 at 10:07 AM
1
Share
10 |10000 characters needed characters left characters exceeded
Kunal Bansal
Feb 23 at 09:18 AM
0

Dear Christian,

Ideally, it should work! We need to analyze the issue in your cloud tenant.

Please create an incident in component CEC-MKT-EXT and you can give reference to this question.

Best Regards,

Kunal

Share
10 |10000 characters needed characters left characters exceeded
avatar image
Former Member Feb 23 at 10:49 AM
0

Hi,

now I implemented SAP Note 2510404 and 2435769 written in this post.

Now when I created new Assignment for Custom Fields in Segmentation with app "Custom Fields in Segmentation", my custom field appears now after saving, but only for new assignments.

The problem now is, that I cannot change or delete already created assignments and their segmentation objects. I saved these assignments before implementing the notes mentioned above and for these old ones, my custom fields still is not shown.

Is there a way to delete the assignments? In the frontend there is no possibility to do that.

BR

Christian

Show 1 Share
10 |10000 characters needed characters left characters exceeded

Dear Christian,

Perfect that notes resolved the issue; for the inconsistent assignment, you should delete from cei_img-> yMkt-> segmentation and delete the inconsistent ones.

Best Regards,

Kunal

0
avatar image
Former Member Feb 23 at 09:53 AM
0

Hi Kunal,

sorry, I forgot to mention that we are running [y]Marketing as an on-premise installation release 1.2 (support package SAPK-12005INSAPCUAN).

Br Christian

Share
10 |10000 characters needed characters left characters exceeded