Skip to Content

Dynamic image path

In my report, I had image object with dynamic path.

The image displays ok when the path is local path on computer ("C:\photos\image.jpg"), but do not working when the path links on local sharepoint server ("http://srv-sharepoint.domain.local/dt/DocControle/image.jpg").

Crystal Reports is launched on a server called srv-erp, and try to access local sharepoint server on srv-sharepoint, in the same local domain.

Thanks for your help to display correctly sharepoint images.

Add a comment
10|10000 characters needed characters exceeded

Assigned Tags

Related questions

5 Answers

  • Posted on Feb 23, 2018 at 08:48 AM

    Hi Nicolas,

    Instead of an Http URL, have you tried with a relative or an absolute "path" to the directory that has the image?

    It usually looks like this:

    "\\server-name\directory\image.jpg"

    -Abhilash

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 23, 2018 at 09:02 AM

    Hi,

    Thanks for your answer, but I have constraint, I must use images stored in sharepoint images library, so these images are not accessible via absolute path as your example.

    On my personal computer, http path works, but not on customer's server.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 23, 2018 at 01:30 PM

    What version of Crystal is running on the customer server. Perhaps it's older than your version and doesn't support url path for images.
    In such a case, you could use a UFL to on-the-fly materialize the image from a url path to a local file path. At least one 3rd-party UFL provides such httpToImage() function.

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Feb 23, 2018 at 03:47 PM

    On customer server : CR 2013

    On my personal computer : CR 2008

    Add a comment
    10|10000 characters needed characters exceeded

  • Posted on Mar 01, 2018 at 09:06 AM

    Is there any rights or firewall parameters to activate ?

    Why CR can't access and show image with http link ?

    Any ideas ?

    Add a comment
    10|10000 characters needed characters exceeded

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.