Skip to Content
0

Configure Saprouter as Service

Feb 23 at 08:11 AM

61

avatar image

Dear Ones,

I configured the Saprouter as service on windows and it is running normally, and I can remotely access the environments. the problem is that I have no connection to SAP, when I use sm59 it gives connection error

Thank you for your help.

Amubai

10 |10000 characters needed characters left characters exceeded

Can you please give us some details? Printscreens or at least describe how have you configured the connection in SM59. What error are you getting?

2
* Please Login or Register to Answer, Follow or Comment.

3 Answers

James Elvin Hizon Feb 23 at 09:38 AM
2

Hi,

If you have "already installed the SAProuter and correctly configure the saprouttab" then you have to setup the parameter in tcode OSS1. Please see below steps

1. Login to your system
2. Go to Tcode OSS1
3. In Menu Bar > Parameter > Technical Settings
4. Click Change
5. Fill up the following fields ( Please do refer to attach file )
6. Save It. Done!

Now for test connection
In Tcode SM59 > Abap Connections > SAPOSS > Click Connection Test.
If you have encountered any error upon connection test feel free to post it here.


Share
10 |10000 characters needed characters left characters exceeded
Yogesh Patel
Feb 26 at 01:12 AM
0

Make sure follow steps above and adding permit entry in saproutertab file to permit connection(James already mentioned it in his answer).

This is the most important step.

-Yogesh

Share
10 |10000 characters needed characters left characters exceeded
Aniceto Mubai Feb 28 at 10:50 AM
0

Good afternoon,

I'm sorry, I still have the same problem of not being able to communicate with SAP.

Here are the settings I have:

# SNC connection to and from SAP

KT "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 194.39.131.34 *

# SNC connection to local system for R/3-Support

# R/3 Server: 192.168.2.xx

# R/3 Instance: 00

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.21 3200

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.20 3200

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.31 3200

# SNC connection to local WINDOWS system for WTS, if applicable

# Windows server: 192.168.2.xx

# Default WTS port: 3389

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.20 3389

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.21 3389

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.31 3389

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.21 9999

# SNC connection to local Portal system for URL access, if applicable

# Portal server: 192.168.1.xx # Port number: 50003

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.20 50003

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.21 50003

# For the HTTP connection

KP "p:CN=sapserv2, OU=SAProuter, O=SAP, C=DE" 192.168.2.21 50000

# Access from the local Network to SAP

P * 194.39.131.34 * 3299

P 192.168.2.20 * 3200

P 129.168.2.21 * 3200

P 192.168.2.31 * 3200

P 192.168.2.20 * 3200

P * * *

# deny all other connections

D * * *

Aniceto


Show 1 Share
10 |10000 characters needed characters left characters exceeded

Hello Aniceto Mubai,

Please look at article below and verify your installation.

https://blogs.sap.com/2014/12/15/saprouter-installation/

Thank you

Yogesh

0