Skip to Content

SUM Error with SystemPKI

Hi All,

We are trying to upgrading SUM Java on Solution Manager. However, we are stuck in the step "Configure SAP Control connection for central instance".

SUM shows the following error during the execution of the current step:SUM has detected that the SystemPKI is supported by your system. To continue, you have to configure it as described in SAP Note2200230.

Also, "DETECT input_credentials input-credentials-dialog check-sapcontrol-connection-for-ci com.sap.sdt.j2ee.services.servicesimpl.CheckSapControlService class com.sap.sdt.util.diag.DiagException"

We went through the note 2200230. We checked the file permission and SECUDIR environment parameter. The file permission has been added for user <SID>ADM and SAPService<SID> for the folder specified in SECUDIR (..\usr\SAProuter) as well as the sec folder of 2 instances of JAVA stack (..\usr\sap\<SID>\SCS03\sec and ..\usr\sap\

<SID>\J02). After that, we also restart JAVA, but the issue is still exist.

Here, <SID> is the system ID of Java instance.

We would need suggestion how to solve this issue. Is there something wrong with BC-SEC setting, what would be the correct setting here?

From the log we see the following error:

[Thr 6416] RSecSSFs: SSFS-1430: File "I:\usr\sap\<SID>\SYS\global\security\rsecssf
s\key\SSFS_TSJ.KEY" cannot be opened in mode "rb": No such file or directory (er
rno = 2);

I checked from the server, the file is not in the specified path.

We tried to update with the following command:

sapcontrol -nr 02 -user <sidadm> <password> -function UpdateSystemPKI

The output of those command from the command line is:

UpdateSystemPKI

OK

However, I still cannot find any file in the path "I:\usr\sap\<SID>\SYS\global\security\rsecssf
s\key"

We would be grateful for any feedback to solve this issue.

Best regards,

Duy

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • avatar image
    Former Member
    Mar 22 at 01:06 PM

    i also faced the same error and unable to get the exact solution.

    Note 2200230 didnt solved the issue though.

    Add comment
    10|10000 characters needed characters exceeded