Skip to Content
avatar image
Former Member

SSO between SAP ERP and MS AD using SAML 2.0

Dear experts,

We want to implement a single sign on between SAP ERP 6.0 7 and MS AD using SAML 2.0.

For this we have installed a SAP Netweaver 7.5 with Idf included. we have mapped this system with LDAP as UME.

In AS ABAP Side (ERP 6.0 EHP7), we have enabled a SAML 2.0 Service Provider, and added AS JAVA as Trusted Provider for Identity Providers.

In other Side, we added also ERP 6.0 EHP7 as Trusted Provider In Service Providers.

Now when we connect to webgui from ERP 6.0 EHP7 system using this url :

https://xxx.sap.com:44318/sap/bc/gui/sap/its/webgui?sap-client=100

the system redirect to :

https://asjava.sap.com/saml2/idp/sso?SAMLRequest=fZFLa4QwFIX%2FimQf85ARDaMgHQpCW4ZO6aK7VK9MQBObG%2Fv4940OlOmiXeZwzznfIXvU0zirZgln%2BwhvC2BI2kNFTpzv%2BC7XPS0y3lEBfUGLvCwp7zMhZS45HzhJnsGjcbYiMo2vFnGB1mLQNkSJi4JySWX2JAqV5YqXLyQ5xAZjddhc5xBmVIyJUqYiL1KRSlmwFUky088M0ZHk1vkONsCKDHpEWIuOGtG8w4%2FyOY0W1TamIou3ymk0qKyeAFXo1Km5v1MRUs3eBde5kdT79VptzP7K%2F7891oJf4UkNfn7V0%2Bm4Z1dBl9RZPURnezi60XRf64JJh7%2BDRSo2xfR02E7VYnGGzgwGepI04%2Bg%2BbjzoEPcGvwBh9aX098fV3w%3D%3DℜlayState=oucqqvqvwadoytqcoredyoywzzoqdtrsswsqqfq&SigAlg=http%3A%2F%2Fwww.w3.org%2F2000%2F09%2Fxmldsig%23rsa-sha1&Signature=s12UyEntZhCw%2B%2B1Z58JHujiM5GBDnMP16Nzk2jrXpMIKynPoWRJ6BzP6%2Bx2CkkBupgIONVBeIBQPBH4KLrJ7SaALzGl4J%2Fhs6mw8fFmUj4P1rLUtkupYeqeYZotAmyeNrFShvrMDKWVYm0BOWmiYIlpqDCCpBmtliD2BM03Iyzs%3D

But this url is not working.

What is wrong in our configuration ?

Thanks in advance.

Best regards

Add comment
10|10000 characters needed characters exceeded

  • Get RSS Feed

1 Answer

  • Feb 26 at 04:58 PM
    Add comment
    10|10000 characters needed characters exceeded