Skip to Content
author's profile photo Former Member
Former Member

DSO Acitvation issue.

Hi Friends,

In my BW system all the DSO Activation processes are getting stuck.(remaining yellow for long time) and then a message comes ..that process terminated as no batch process was available .resource error.

"Resource error. No batch process available. Process terminated "

Please tell me what is the reason for this ..?What settings I can do for this to fix up as its happening in all the DSOs

I checked up some soultion offered which have not worked..like changing the settings in RSODSO_SEttings to make the process of activation and sid generation as dialog and parallel process as 2.which I tried both in the chain and manually.But it didn't work at all.

Is there some memory buffer settings to be made??

any help will be duly appreciated.

Regards,

rk

Add a comment
10|10000 characters needed characters exceeded

Related questions

4 Answers

  • Best Answer
    author's profile photo Former Member
    Former Member
    Posted on Jul 11, 2008 at 06:01 AM

    This is due to unavailability of batch processes, you may request basis to increase BGD's. ( Convert

    dialogues to BGD's )

    Check out the avialable BGD's in SM50, there may be too many jobs running in parallel.

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 12, 2008 at 01:20 AM

    As a sanity check the SM50 tcode to see how many BGD or DIA process available while you are actually running the activation of data jobs ,try to match and tweak the RSODSO_SETTTINGS based on the SM50 first.

    Hope it Helps

    Chetan

    @CP..

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 11, 2008 at 06:04 AM

    Hi Rakesh,

    "Resource error. No batch process available. Process terminated "

    This error occurs when there is no batch process available for the Background Job. You can check the same in SM50 transaction.

    Simply ask the basis people to Increase the Number of Background batch Processes.

    Regards

    Hemant Khemani

    Add a comment
    10|10000 characters needed characters exceeded

  • author's profile photo Former Member
    Former Member
    Posted on Jul 12, 2008 at 06:15 AM

    Thanks everyone,

    I changed the no. of background processes to 4 along with 4 dialog processes in Transaction RZ10.

    It works fine for me know.Actually initially there was just one BGD process defined ,which was causing the resource problem.

    its great to see u chetan,as active as always.......I have changed company so I have logged as a new user,but I hope you remember me.....as we had a long discussion on old and new authorization concept in one of the threads.

    rocks

    Add a comment
    10|10000 characters needed characters exceeded

    • Former Member

      Hi Rakesh,

      You can also try following steps if you get same error again...

      RSA1 >Administration >Current Settings >Batch Manager >Settings for Parallel Processing >select " ODS Activation" >select your DSO just maintain it to 1 or 2, try tweaking these processes and make sure you have enough background processes.

      Regards,

      Shalin Shah

Before answering

You should only submit an answer when you are proposing a solution to the poster's problem. If you want the poster to clarify the question or provide more information, please leave a comment instead, requesting additional details. When answering, please include specifics, such as step-by-step instructions, context for the solution, and links to useful resources. Also, please make sure that you answer complies with our Rules of Engagement.
You must be Logged in to submit an answer.

Up to 10 attachments (including images) can be used with a maximum of 1.0 MB each and 10.5 MB total.